After changing video mode, exported video is half length

Hey guys,

steps what I’ve done.

Starts making project and first import video with 30 fps 720 x 1280 then add videos with 60 fps 1920 x 1080.
Exported video was about 5 minutes, but it has ratio from first imported file, so decided to remove the first imported file and all files included in project was 60 fps FHD.

Then, exported video had ratio from removed first input video and black border (look at atached image), so go setting -> video mode -> automatic and ratio was fixed, but then exported video is incorrect. It’s 2x speed and lasts half time of project.

Is this a bug or I’m missing something? ’

version: 18.06.02 Windows 64bit

Are you saying that you made a new project, with Video Mode set to Automatic, and imported a 60fps video first?

Or did you use the same project, where you had initially imported a 30fps video, and select “Automatic” again?

If you started a new project from scratch, set to Automatic, and have only worked with 60fps videos, and are attempting to export at 60fps… I have no idea what’s wrong.

But if you’re still using the same project, rather than use the Automatic setting, select a Video Mode that matches your video clips, such as 1920x1080 60fps, and try exporting again.

I’m under the impression that “Automatic” only cares about the very first clip that you load.

Second one, same project with where initially imported a 30 fps video, but then removed it.

So after a few attemps, I’ve figured it out.
When use settings -> video -> automatic, export resoultion and aspect is updating, but after exporting videos is at 2x speed.
When set resolution, ratio and fps mannualy (same as automatic set), in shotcut preview ratio do not change, but after export everything is ok.

So, to sum it up, settings -> video -> automatic seems to update preview and corrupt speed at exported video (propably due to change from 30fps -> 60fps) and setting right video properties mannualy do not update preview, but exported video is ok.

Attached pictures describes the case.

Screenshots

I’m having a similar problem in 19.07.15 and surprised this old bug hasn’t been fixed yet. I didn’t know about video mode until I exported and my video was sat in the middle of a big black rectangle. When I realised that the project had picked up the resolution incorrectly I tried changing to a different video mode from the settings menu, but when I change the mode to a different preset my project drops from 1m40s to 1m20s in length (or even shorter if I try a 60fps mode) and every single clip stays in place but has the wrong video - the splits have moved. There is no speeding up of clips that I can see, I just get wrong stuff that ends early.

After a few hours of fiddling around (including starting to make the whole thing again from scratch and getting fed up) I managed to get an export at the full original resolution without any black borders. It’s really weird, but it seems that even though my source (and the bulky .mov files Shotcut converts to) are in 30fps, everything gets completely messed up unless I make a custom video mode at 25fps, so that’s my solution for anyone else who gets their project stuck in this state - switch video mode, but keep fps the same.

I think the moral of the story is probably that for now we need to take great care to set the video mode at the start of the project before importing any clips and save a lot of hassle later on.