[21.05.18] Crash every time adding a video

Pop!_OS 20.10 with NVIDIA 460.73. Using the AppImage of 21.05.18. I was able to add a few videos to my project, but adding any videos to the timeline after that causes the app to crash every time. If it helps, here’s the info I got from the terminal:

Sorry, but unable to reproduce on Ubuntu 20.04. Does a previous version of Shotcut work?

Does a previous version of Shotcut work?

No.

Can you test 21.03.21, not 21.05.01 where there were major changes?

When I open the project on 21.03.21 it asks for recovery, but recovery fails.

Please stay on track. Test the same thing you reported about but with this earlier, known stable version. When I say “known stable” it does not mean it is free of bugs (no software is), and that it works on all computers (it does not). It simply means it was at the end of a period of stabilization before major changes introduced.

The “my project” to which you refer:

Was it made before the 21.05.01 release, with an earlier version?

If it was made with an earlier version, can you have an MLT of that project from before 21.05.01, an MLT that was untouched by 21.05.01 and untouched by 21.05.18?

If so, can you open that untouched MLT in an appimage of 21.03.21, repeat the steps which led to the crash in 21.05.18, and report the result?

The “my project” to which you refer:
Was it made before the 21.05.01 release, with an earlier version?

No, the project was created with 21.05.18.

I restarted the project with 21.03.21, had no issues adding any videos to the timeline.

OK thanks, duplicate of

Yes, it seems similar to the issue I had addressed some time back.