Youtube is degrading Playback quality massively, need Expert settings

Hello @all,

I import gaming videos recorded with Fraps into Shotcut, then export them as .mp4 with H.264 High profile, using the settings youtube is recommending (2 B-Frames and GOP= half the framerate) on INSANE 70 or 80% in quality mode. Videos are recorded in 1080p60 and exported as this. When I play the exported locally file it looks just like the fraps file for me, everything is perfect. But then when the exported file is uploaded and ultimately processed by Youtube, playback quality suffers from two major issues=

  1. the black bars at every race intro are not fully black (you can see that when you play it in the 720p setting where youtube puts true black bars left/right of the video) and
  2. there are blocky artefacts all over every few seconds. Watch this:

Export settings are= Videomode: automatic / H.264 high profile / 1080p60 just like source file / Interpolation: Lanczos / Codec quality mode on 70% for example, GOP 30, B-Frames 2 and until now NO change in the other field where the fast-start entry etc is.

So as long as there is footage with no or very slow movement of the scenery, plaback quality is fine. Also static recording with small moving objects like other cars driving around while i dont move works too. But as soon as the whole scenery is in motion, the problem begins. I tried the Youtube video improve option on one clip which then corrected color/contrast so I got a true black but the artefacts are still there.

So that does NOT help because the block-artefacts are the big issue. I know of other players who dont have this BUT most of them upload videos in such low Bitrates (CBR or VBR mode instead of CQ/CRF) that the whole video looks bad anyway. I could have very good quality if I can get rid of a blocky video image every few seconds.

So the questions are=

Do I have to switch to another codec and if yes, which settings?
On H.264 -do I have to change GOP / B-frame value against Youtube recommended setting or do I need additional commands in the misc field where vpre etc is?

Have you tried ‘constant bit rate’ instead of VBR? When I did VBR it just made files gigantic but I lost tons of quality even at 80%. for 1080p60, try constant bit rate at 50M, it still makes the file size really small for me but the quality is pretty close to the original. I used the settings here without artifact issues. CBR 50M, 2 B-frames, GOP half frame rate (30 in your case).

Thanks for the tip, sadly it also ends in the same.

For me, Quality mode on 70-80% got me the best visual results when played locally, VBR mode for example reduced quality. Thats why I used the Quality mode until now. Still dont know why Shotcut / libx264 doesnt give me the CRF option, whatever…

Now I tried CBR, Dualpass (SinglePass did not give the desired bitrate), 60M, 2 B-Frames and GOP 30 and this is how it looks like.

Of course you’ve seen that :

50M is very high that’s why maybe youtube re compress it.

Maybe you could ask on Youtube help for that?
You show them a sample of your file and point to a youtube link imported and ask them.

  1. yes i know of that and guess what, youtube re-encodes ANYTHING uploaded. It doesnt matter what you upload, YT is using fixed presets to compress videos further for playback.

  2. Yep its very high because that ensures the best possible quality because of the Youtube compression. Bad source= bad quality playback… If i would upload stuff in those poor 16mbit for FullHD the source footage would look very blocky already.

  3. Yes, i did ask on the german google forums and still the same default answers about youtube re-encoding videos etc. Nothing new Nobody knows a solution to my problem.

So for me it doesnt matter if I choose CBR, VBR or quality mode, playback always gets distrted.

Fun fact 1= One of my videos got improved by youtube once it got more than 100 views. But it contains a slideshow only so I only know about the contrast-fix which Youtube applied.

Fun fact 2= I tried a trial version of Adobe Premiere Pro. Exported video on its Youtube preset (which is fixed at those poor 16mbit) and it looked crappy. Then I exported things manually as H.264 and that oh-so Pro tool didnt even offer me CRF mode or decently high bitrates at all. Useless.

I save it as mp4 and modify the output resolution.1,920x1,200.
Hope this helps.

Andigelb sorry for reviving this post. have you manage to solve this problem? I’m facing the same issue when editing gopro videos. They look fine locally but crappy after upload for youtube. I have tried so many different settings, including youtube recommendations, without luck.