You are running low on available memory!

There’s plenty of swap available, I use zswap for memory compression. I know this is to warn users of bad performance, but I just want to use the program without it throwing me this, for me, unnecessary message every 5 minutes. I’m stuck in an environment where memory pressure is normal.

I know how to use my computer. Please just add a tick or button to not remind me. I know of the risks and shortcomings.

1 Like

Agreed with this. It would be nice if there was a toggle or checkbox for “Don’t show this warning again.” when closing the low memory warning.

I will not add a checkbox for this because most people will turn it off and forget about it and then complain Shotcut is crashing or making their computer run very slow due to swapping. So, I will add a non-visible configuration option so only an advanced user can disable it.

1 Like

This is added to the next version with a boolean configuration item with key warnLowMemory. The configuration page on the web site will be updated when the release is published.


Fantastic, thank you. Sorry for the late reply.

1 Like