Wrong window size, tools are missing cause of that

Linux Mint 20

Version 20.09.13 64 Bit

Hello guys,
So I just downloaded Shotcut on my new Laptop with Linux Mint 20. I have the problem that the size of the window from shotcut is a little bit too high and I cant drag it down further becuase it gives me the limit of 581 pixels height. The issue with this is that I cant use the bar to move the position of the Video/Audio Track since its no there cause of the height. (see screenshot). Then there is the option to change the timeline bar to a higher version but than other options from the shotcut surface are covered.
Can anyone help me to change the window so that I can use the bar to change the position from the Video/Audio Tracks?
I hope you understood my imperfect english.

Not sure what mean by bar.
If you’re looking for Audio Waveform, the clip needs to have audio on it.

If you’re looking to resize the window, just click here and move up.

Click this box here to open up additional actions.

1 Like

I don’t think this is a Shotcut problem.
I searched this on Google :“how to make a window fit the screen on linux”

And found this answer:

When a window is bigger than the resolution of the monitor do the following:

  1. Press and HOLD ALT (On Ubuntu 18.04+ Hold SUPER ) and then simply click and HOLD the mouse button over the window you want.
  2. Start dragging it until you can see the top part or at least a corner to resize it.

On Windows we have this button on the corner to fit the window to the screen… You don’t seem to have it

1 Like

I just noticed the screen doesn’t have maximize box.

I wonder if there is an option in Linux like it does in Windows to Exit Full Screen

1 Like

@Hudson555x Yep. That could be easier that way.

1 Like

I do not understand it either. In any case there is a minimum height to the timeline by design since it is a very important UI element and too many users get confused if it is too short. If you do not want to see the timeline temporarily, close the panel. Closing the panel does not remove the timeline from the project. Then, click Timeline on the main toolbar or in the View menu to reopen it.

1 Like

@shotcut The way I understand it is that the Shotcut window is larger than the screen resolution of his Linux laptop and he doesn’t see the scrolling bar of the timeline

1 Like

The somewhat old version of Qt used in the portable, AppImage, and Snap have issues with Hi DPI on Linux. That is a factor in your screenshot. The Flatpak is using a very new version of Qt, which is better in this regard. Or you can try the command line option:

1 Like

OK thank you all for your quick amswers. Yep @MusicalBox I meant the scrollingbar. Recising the window doesnt work since there is a limit in height at 581 pixels.
@shotcut ok that QT thing might work but when I type in the terminal : “shotcut --QT_SCALE_FACTOR 1”
it says: “bash: shotcut: command not founded”

1 Like

This only appears when it is needed: when the project duration is longer than what fits into the timeline.

it says: “bash: shotcut: command not founded”

It depends on what you downloaded or how it was installed.

1 Like

Ok thank you it worked!!! after using “/snap/bin/shotcut --QT…1.” instead of only “shotcut --QT…1” since I downloaded shotcut also via snap. Now the window has the right size + I have the option again to minimize and maximize the window :slight_smile:
Thank you!

OK but now it doesnt safe this option… I always have to type the command “/snap… 1” in the terminal to start it… So is there a way to run shotcut not via the terminal?

Yes, but not with that option as far I could find. You can patiently use launch it like this until a version that upgrades Qt in the snap comes along in roughly a month. Unfortunately, this option must be applied before the app can be initialized enough to read its configuration file. So, that is why it is not available through settings. Technically, also, you can set an environment variable as well but then that ends up affecting all your Qt apps, which is usually not desirable.

1 Like

Ok I partially understand that. Thanks for your help :slight_smile: I will just run it via the terminal then for now on.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.