Wrong video length after importing intact file

Windows 10 Pro 1903 x64
Shotcut 20.07.11 x64

Can you repeat the problem? If so, what are the steps?
I’m trying to import two .trp files to the Shotcut timeline. Here’s what VLC says about the files.

(see pictures below)

After dragging them to the shotcut source video list, the second video “vid.001” is shown with a wrong video length which is shorter than expected. The file isn’t corrupted and VLC views it to the end without problems.

image

If I try to add the second part to the timeline, it’s still not the full length of the video.
How can this be solved? A bug? Thank you.

Kind regards,

Catfriend1

“New users can only post one picture at a time”

-> annoying if I try to make a good bug report.

  • vid.trp
    Length: 1h 08m 09s
    image
  • vid.trp (continued)

  • vid.001
    Length: 1h 36m 50s
    image
  • vid.001 (continued)

We use the length provided by FFmpeg. You can override it in Properties. To see this length reported directly by FFmpeg, open cmd.exe, cd to the directory where Shotcut is installed, and run ffprobe followed by the full path to the video file (drag-n-drop file from Explorer to the Command Prompt window).

Yeah, ffmpeg must be wrong about the video length. So the ticket has to go to them instead? Where can I report such a problem?