Wrong Aspect Ratio - Export Adds Padding

What is your operating system?
Windows 10 x64

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.07.11 x64

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

Shotcut doesn’t always interpret the source aspect ratio correctly. When this happens, SC adds padding to the h.264 lossless export.

I work with a lot of 2nd-gen, 3rd-gen, etc sources. Maybe early generation digitations that don’t follow current standards, etc. If the source file doesn’t have any padding or edge defects, I’ll just use the Automatic video mode. Sometimes they have letter-boxing, pillar-boxing, edge artifacts from analog video capture, etc. I those cases, I figure out how much source cropping I need to get rid of it and make a custom video mode and Crop:Source filter.

The worst feeling is to see padding after a 2 hour export and have to re-do everything.

Here are some examples. The Application Log I attached is for Example 1.

The work-around is usually to manipulate the source file’s PAR before import (e.g. MP4Box, MPEG4Modifier, WMV Aspect Ratio Changer, etc.), but that technique didn’t work in Example 1.

Example 1: Source 720x404 PAR 404:405 actual DAR 16:9
Shorcut says the source is DAR 16:9
Exported file had PAR 254:255 and 2x padding on the bottom

Example 2: Source 624x352 PAR 1:1 actual DAR 39:22 (15.955:9)
Shotcut says the source is DAR 16:9.
Exported file had PAR 255:254 and 2 px padding on the right side
wanted output to be 1:1 without spatial interpolation

Work-around: use separate tool to modify the source PAR to 352:351 before importing in to shotcut.

Example 3: 852x480 PAR 1:1 actual DAR 71:40 (15:975:9)
Shotcut says the source is DAR 16:9

Example 4: Source is letter-boxed. 1920x1080 16:9 DAR (1:1 PAR). 130 px padding top and bottom 1920x820 content (96:41 DAR, 1:1 PAR)

Goal: scale to 1120x480 (96:41 DAR, 288:287 PAR).

Created a custom video mode 1120x480, 96:41 aspect ratio. Output tab shows 1123:480 aspect ratio, which isn’t right. The custom video mode would have an equivalent display size of 1123.902439x480 with square pixels).

Result #1 (leave export tab as-is 1123:480 DAR): Output 1120x480, 595:254 DAR, 255:254 PAR, 2 px padding on the right side

Result #2 (change export tab to 96:41 DAR): Output 1120x480, 1123:480 DAR, 1123:1120 PAR, no padding, 0.1% smaller file size than Result #1

Example 5: 854x480 PAR 1:1 actual DAR. Shotcut reads as 16:9
16:9 requires PAR 1280:1281
720x404 log.txt (45.8 KB)

Here is a sample file. I forced 16:9 DAR EXACT by setting PAR 404:405. Automatic Video Mode. h.264 lossless export has padding as-described.

example source.zip (689.6 KB)