Wont open (linux appimage)

the filename is shotcut-linux-x86_64-240229.AppImage

after trying to open the appimage nothing happens.
the console says:

bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by bin/shotcut) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Charts.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Multimedia.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Widgets.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.26' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Widgets.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.28’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Widgets.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.28' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Xml.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.26’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Xml.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libmlt-7.so.7) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libfftw3.so.3)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Quick.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.26’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Quick.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.28' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Quick.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6OpenGL.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Gui.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.26’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Gui.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.28' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Gui.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Qml.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Core.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.26’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Core.so.6)
bin/shotcut: /lib/x86_64-linux-gnu/libstdc++.so.6: version GLIBCXX_3.4.28' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libQt6Core.so.6) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libpulse.so.0)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libpng16.so.16) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libicui18n.so.66)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libicuuc.so.66) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libpulsecommon-13.99.so)
bin/shotcut: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.30' not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libsystemd.so.0) bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libsndfile.so.1)
bin/shotcut: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29’ not found (required by /tmp/.mount_shotcu3GCSVP/usr/bin/lib/libFLAC.so.8)

i actually don’t know what this means

I just tested the same image downloaded from here (I assume you got the file from this site) and it works fine for me on Xubuntu 22.04 and Arch.

Since you didn’t give much information - like which version of linux, whether you have you used AppImages in the past, was it made executable etc - I would re-download and try again.

lmao i forgot the most important stuff
i use debian, dont know which version of debian, it was made executable and other appimages do work

I figured most of that was probably the case else your Linux experience wouldn’t be very pleasant! I would try downloading again, or even see if the immediate previous version works for you.

where can i get the previous version?

Your Debian version is incompatible. The minimum version is listed in the download page and FAQ. The download page has a link to get older versions. Try the 22.12 version.

1 Like