Why stutter?!


this is a thing what I always wanted to ask:

The part in the middle was one track lower and while Playback it run smooth.
Then I put it one track higher and stutter! And not to misunderstand…, even if I put it back into the previous track…, the stutter stays.
(In that case the part has no blending, no mask only a normal piece of video.)

Why is that so? BTW, this happens often to me…, it runs smooth in the Playback and changing a *small thing, not even a filter, suddenly stutter…

Best regards

Is video.mp4, Pexels Videos26, 20191223_094905.mp4 all the same video resolution & frame rates? Do those match the Video Mode?

To see the project’s video mode click on Master, than Properties.

Tried to duplicate, but couldn’t. 2 Videos same resolution, one video 60fps, one video 30fps. Video Mode 1080p, 60fps. Shotcut 19.12.31, Windows 10, SSD’s used.

That is difficult to duplicate…, it comes out of the blue sky, you know what I mean?
The thing is, that nothing importing has changed, (also) maybe moving a little to left/right turns suddenly to stutter, where it run smooth before.

It does it again! Out of the “Blue Sky”!
Suddenly stutter! Two tracks only!

Before the third track…smooth!
While third track heavy stutter!
After the third track…still stutter!
Directly playback after the third track…smooth!

Do not misunderstand me! But this is bringing the whole project down! You know what I mean?! I really would like to make a cool (IMO, of course) video, but I let pass this and that and that too, because already only of that behavior. :frowning:

Had to be written…
'Til then…

I have deactivated the video tracks specially except V1 and V2, because of stutter!
(I wanted them to export and to import again…)
And I started playback…

But it has the absolutely same behavior as if all tracks are activated! Absolutely the same!’! First smooth, stutter, smooth, as if all tracks are activated!
I need to say: It starts frustrating me! :unamused:

You’re not posting any information/steps that others could attempt to find the issue.

How could I do this?! HOW!

That is much better:

While ‘A’ was stutter, ‘B’ was smooth!
Suddenly ‘A’ was smooth, but now ‘B’ has stutter! WHAT!?

How can I give more info about that behavior?! TELL ME! How…

'Til then… :unamused:

And not to misunderstand:
I’m not talking about a little stutter, like “tik tik tik” (or so), no, it’s STUTTER with “felt” jumps of 10, 15 frames!

What are your timeline properties? Click on the “Master” track head then look at the Properties panel. We need the resolution and frame rate.

You may have posted elsewhere, but what type of processor is in your computer?

As an experiment, what happens if you do Convert to Edit-Friendly on your clips and try again? There could be something about the encoding of the source videos that makes seeking very difficult.

As for being smooth and then stuttering, bear in mind that Shotcut renders slightly in advance of the playhead during playback so that frames are ready by the time they’re needed, and is also discarding frames as memory fills up. This is why it will stutter during playback with a clip on V3, but if you stop and restart after the clip on V3, it will be fine. Shotcut is caching differently now for the new region and has nothing to purge and no V3 to precompute. (Loose paraphrase of course.)

But not at only two tracks! And one single blend filter!
Yesterday I had a heavy stutter, 3 tracks, 2 vids, one PNG, and the stutter was with the png!
You know what?! I edit for reasons the PNG (a little bit erasing only) and, you know what<?!>…, it run smooth…, exactly one time. Then again stutter, heavy stutter.
This f***g stutter is really frustrating me, I will tell you!

You have a good idea (IYHO) for your video, needs 6 tracks and is including one or two “Simple Shape” filter and some more…
Let me tell you, what your very next idea is: “Forget it! Not realizable…”

I get that you’re frustrated, and that’s understandable and unfortunate. But it will be your own fault if you don’t answer the three questions I asked.

Of course…, what else. We will see this year.

@Hudson555x and I took time out of our day to look at this problem with you. We asked specific questions. This thread is now 11 messages deep without an answer to a single one of them. We’re at a loss to help you without that information. What would you say if you were in our shoes trying to help? We’re not trying to be combative. We’re genuinely stuck until we have more information to work with. You’re skilled enough and have been around long enough that it shouldn’t take 11 messages to pull it out of you. Let’s set frustration aside for a moment, look at the data, and get this fixed for you so you can enjoy Shotcut again (assuming you did in the first place LOL).

Is Settings > Realtime on?
Performance is already a known problem, which I have told you before. As for the unexpected inconsistency you experience, I cannot explain. I do not have your computer and project. Sometimes people need to wait until I experience something until I address it. The next version will have preview scaling, which will help but not entirely depending on how much scaling is required depending on a proxy workflow.
I see you are changing the speed on a mp4 file. That mp4 file probably has temporal compression (not all I frames). A speed increase can cause seeking on the file, and seeking on temporally compressed video is much slower. That is probably what you are experiencing. Convert to Edit-friendly converts it to all I frames thereby removing temporal compression. A speed reduction does not cause a problem because there are no frames to skip, it just repeats frames from a cache. Austin also explained how a render-ahead thread and buffer can cause delays in when you experience the problem. In your screenshot, after the clip with 1.4x speed starts until you experience the problem, the buffer is not empty. The problem then appears when the buffer goes empty and remains this way until the 1.4x clip ends.

Only FYI, no discussion necessary…

Two days ago it looks like that:

Yesterday I added some clips…, at that position as to see in the picture, only there…
And the result:

Felt 90% of the time I try to avoid stutter, by source, by brain. Only 10% for creativity.

It was smooth! And then…, it did it again:

(‘Part A’ is Text, only text with (at first a FadeIn)…)

What happend…

I sized ‘Part A’ over that ‘Heavy Parts-01’ part.

And I then added to ‘Part A’ a FadeOut. That’s all!
The stutter stays, even after a restart of Shotcut.
I need to resize ‘Part A’ to not overlap ‘Heavy Parts-01’, then it’s again all smooth…

++Further explanation++
I tried a little…
I replaced that Text part with a simple Color part, but/also overlapping.
And it was smooth!
Then I changed the color to Black and full transparent (Alpha == 0).
Then it was still smooth, but at the beginning of ‘Heavy Parts-01’ it stopped a little, but then again smooth.
Then I placed the filter ‘Simple Text’…, and at once heavy stutter as soon as ‘Heavy Parts-01’ starts! And the stutter remains! Until a next part in the timeline. Then again smooth. HTH

Can you please<!> fix it? To the next release? I would be very grateful!

In that sense TIA and
best regards