Why only one "stereo" instead of three "6 ch ac3"?


#1

Hello,

I have a H.264 video file *.mkv with tree audio tracks “6 ch ac3”.
When I cut a piece of this file and export it, I get a new video file with only one “stereo” audio track.

Which settings should I use, to get a new video file with the same three audio tracks “6 ch ac3” ?

Thanks in advance.


#2

Is this still the only solution?

"…If you want to preserve your channels, you can add channels=6 in the Other tab of the export dialog.
You can replace the 6 with the number of channels you actually have. I had to look into the source code to see how it was implemented. The default value, when not specified, is 2…"


#3

That (channels=6) will only preserve one audio track with 6 channels. Shotcut does not support using multiple audio tracks from a source clip. You have to choose one of them to work with in Properties > Audio tab. You could add the clip three times to three tracks in the Timeline and mix them all down to a single 6 channel audio track output. Be careful applying any audio filters that deal with channels such as Balance, Copy Chanel, or Pan as they do not handle more than 2 channels. These are the only options at this time.