Why is the project(-timing) broken? Clips all of a sudden have wrong (double) length

Hey guys.

I did start working on a project and finally had the clips synced (was tough in this case). After opening the save project, I was shocked: Clips on Video-tracks were not in the meant to be order anymore. Playlist shows double the length of the original clip lengts. Why?

I will show a screenshot of the broken project, and of a project I did rebuild roughly, just to give an expression how the original file was looking, prior if broke somehow…!

I am on Win 8.1 64bit with 8GB Ram and I7-4500U CPU and Shotcut-Version 19.06.15.
Video files are 1080p, 30FPS all re-encoded with Handbrake prior importing to ShotCut…

What are the original FPS of the source-fims?
Did you change “videomode” while editing your project?

All source files, which have been imported to SC have 30FPS fixed frame rate.
The original files (never seen by SC) have had different FPS 29,xxx and 60.

It is possible, that I did change something in the Video settings, because I was wondering, what the current project settings were and in “videomode” nothing was highlighted.
Is there a way to see the current videomode-settings somewhere in SC?
If memory serves right, I did push 1920x1080, 30FPS. Could this have something to do with my issue? Is it reversible?

In the MLT-file of the broken project has the following content at the beginning:
<profile description="automatic" width="1920" height="1080" progressive="1" sample_aspect_num="1" sample_aspect_den="1" display_aspect_num="16" display_aspect_den="9" frame_rate_num="30" frame_rate_den="1" colorspace="709"/>

The new, roughly rebuilt project looks like this (Automatic Video mode was choosen prior an file import):
<profile description="automatic" width="1920" height="1080" progressive="1" sample_aspect_num="1" sample_aspect_den="1" display_aspect_num="1920" display_aspect_den="1080" frame_rate_num="30" frame_rate_den="1" colorspace="709"/>

If there is no project opened or newly created, then see Settings > Video Mode. This will apply to clips that are opened and then playlist and/or timeline if you start a project by adding the clip to either of those.
Otherwise, In a timeline project, click Master in the top left corner of Timeline to select it and view Properties.

I’m still trying to figure out, what happened to my project. Mainly because I’m afraid, that I’ll loose my work again in the future.

The Maser-properties show 30FPS (as the clips are).
The clips duration is twice the “real” lenght, while the meta data shows the correct length.

These clips play on regular speed, and as soon as the playhead is moved past 50% of the total length (past the original lenght), it’s just not showing any picture/audio, which seems correct, because there is no more data to show…

I am not sure what happened. You might be affected by this bug report when changing Video Mode after loading a project:

The metadata DURATION value you shown is not very trustworthy. It is not written by default by ffmpeg/libavformat, which is wrote your file. Rather, some tool must set that value. I am not saying this is your problem or related; I am simply pointing that out.

I guess that’s the problem, thank You!

Metadata is not “trustworthy”, I agree. Just wanted to show that the Metadata is in line with my original file, which has the proper timing (and works in a new Shotcut project without an issue). I won’t touch the “Video mode” setting any more for now.