When I read a video in shotcut, it skip frames at some places, this bug is still there when compressing the read video

Hello
I have an important problem because I have to create again lot of my videos.:frowning:

When I insert a video into shotcut, and read it, it sometimes lags,but I know it may be the result of a slow processor. So I decided to not take care about that.

But in fact for me there is another deeper problem.

When, in shotcut, I read a video, it skip some frames of the readen video!!
I’m sure of that because when I move the cursor/selector on some part of the video frame after frame, the same frame is displayed whereas it shouldn’t.

So because I already created a video which I inserted in another video both in shotcut. Now I’m stucked :frowning:

Do you know where my problem come from?
I think it may come from the version which may be too old because of bad ubuntu updates ( I installed shotcut from a Ubuntu package, not the first time a got a problem with Ubuntu packages).

Sorry if I don’t talk perfectly english, I’m french.

Thanks

What is your operating system?
Linux Ubuntu 20.4

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.10.31, certainly 64 version

Can you repeat the problem? If so, what are the steps?
To repeat that I only have to insert some videos tanken from my mobile phone or from Shotcut, insert it into a shotcut video. I 'll skip some frames, not only in my view but also in the created video.

Apparently it’s not because of an old version, because it seems I have the more recent version :frowning:

Any bug report that simply says “it lags” is rejected. I think you should use something else.

thanks for your answer, do you have the content of my topic in order to copy it and only change the title?

Oops I thought i was in the personal message part of the site.

can you put my topic online again?

It seems it’s not online.

Thanks

here is the link to the video of the bug:

This is simply the way preview is due to image processing. It drops video frames to try to keep real time and the audio more continuous. You need to export it if you want to see it play with full frame rate. You can use the following to improve speed of preview:

If you still see the problem when you export, then Shotcut has a problem reading your video. It does not support variable frame rate video, and most mobile phones capture with variable frame rate. This is not something that will be accepted as a bug. Video editors cannot simply work with every possible file even though Shotcut tries very hard to. In that case, you need to use Properties > Convert to convert the video into a format that is edit-friendly.

Thanks, indeed after converting my sequence it works! :slight_smile:

Yes that is strange that shotcut can’t read variable frame rate video. That should be difficult to program I guess, that would be good if this function works, or at least send a message is displayed to tell it may loose frames when inserting such a video, and that you should convert video not to loose frames. It’s just an idea.

Best regards.

There is code to try to detect variable frame rate, but it is a guess/heuristic. When it does, it display a warning dialog with conversion options, but there is an option on this dialog to never show it again. It is possible you chose to ignore that a long time ago. Also, Properties displays “variable” next to the frame rate when it detects that. I am happy manual conversion worked for you.

Yes indeed, I certainly read the dialog box without really taking care. I frequently close dialog box without taking care, sometime unfortunatly, it s important :smile:

Thanks for your previous answer.

I hope I won’t disturb you, but I still have few problems about skipped frames in exportation.

It’s maybe not a good way to do, but I edited some video from my smart phone in shotcut, exported them, and then edited the output again with shotcut.

I did it with avi format with H264 codec, and I have less problem but I still have some frames loosed.

Even when I convert the original file :frowning:

Can you suggest me an output format which could be safe to be put again as an input in shotcut?

Thanks

I also noticed that the exported fps rate is slightly different from the input file. Does it matter?

All output from Shotcut is constant frame rate. So any format works. If the goal is to reduce generational loss (a different issue than frame skipping), then good options are H.264 at 68% quality or use DNxHR HQ format.

Yes, that matters a lot and can account for skipped/lost frames due to frame rate conversion.

If the phone FPS is 30, it actually means 29.97. If it is 60, it actually means 59.94. If the phone FPS is some other value, then it’s a variable frame rate video that will need Edit Friendly conversion. The conversion does the best it can, but there are situations where a frame may have to be duplicated or dropped in order to fit the new frame rate. That’s just the nature of VFR.

Thanks for your answer. It helped me a lot to know that all output format from shotcut are at constant frame rate.

I was long, but I think I have found the problem responsible for my bug, it may interest you because I believe it’s a bug of shotcut:

Apparently only when I output video from shotcut in avi format in h264 codec (with nvidia encoder or with libx264, and both in linux and windows), and this video is inserted in another shotcut file, the file is badly read in the second shotcut file, so both the display in shotcut and the output of this second shotcut file skip frames frequently.

It skipped something like 4-12 frames about every 10 seconds.

When I changed the export format of the first video to mp4 format, the problem was resolved (apparently, i’ll check the whole video tomorrow).

If you think it’s a bug, and if you want to understand and remove this bug, I can send you part of files which have the problem?

Best regards.

Thanks

If it is a bug, it needs to be reported to the FFmpeg team. That’s the component that does the parsing and encoding. However, this would be considered obscure because H.264 isn’t really expected to be in AVI.

H.264 with B frames is not supported in AVI. Honestly you should not be using AVI for H.264 at all. Shotcut Advanced Export mode is not designed to protect you from yourself. It assumes you are advanced.

yes, changing format to mp4 was the solution, now there is no more frames skipped.

I’m quite a beginner, i learn aloned. I didn’t know that fact.

1 Like