When exporting with opus audio format there is no audio in the video

I am running latest windows version of Shotcut. When I tried to export audio file as mp4 video with opus audio, the resulting video had no audio when I played the video. I also use flac, aac and aac_mf audio formats to export videos and I don’t remember having any problems whatsoever with audio.

Could you provide a screenshot of your export settings? This sentence is difficult to understand. FLAC and Opus are both audio formats, so which one was actually chosen? Also, MP4 is not a video format. It is a media container for a wide variety of video formats. MP4 does officially support Opus, but not all media players support playing back Opus in MP4.

It was a typo. I meant opus audio and mp4 video. I apologize for confusion

So those are approximate export settings I used in that case when I encountered the problem

I even exported a video right now and got the same problem I’ve mentioned. When I play the video, I hear no audio at all nor does audio peak meter show any audio at all.

Read the export job log

[opus @ 0x7fadc5e379c0] The encoder ‘opus’ is experimental but experimental codecs are not enabled, add ‘-strict -2’ if you want to use it.
[opus @ 0x7fadc5e379c0] Alternatively use the non experimental encoder ‘libopus’.

If you had checked one of the WebM export presets that include Opus you would see that they are using libopus

So I added strict=experimental because I had no idea where and how to add -strict -2.
But now there is audio playing when I play the video, although audio sounds fried?, bit crunched? (I don’t know how to describe it properly)

Use libopus because I am not going to help you with opus

Alright. Thank you for the advice.

This topic was automatically closed after 89 days. New replies are no longer allowed.