What needs to be done to use hardware encoder in Linux?


#1

I’m running Fedora Linux 28 on a i7-5960x with 1080TI GPU. I installed shotcut from flatpak and it is running just fine. However, when I click “Use hardware encoder”, I always get “Nothing Found”. If I force h264_nvenc, which I believe is supported in the 1080TI, the final export is a black blank video (although, I can hear the audio). I’m using nvidia driver 410.78 with Linux kernel 4.19.10-200.fc28.x86_64.

What do I need to do to enable hardware encoders?


#2

I guess this does not work through Flatpak. I am not sure what is needed for Flatpak due to its container. You can try not using the Flatpak version if you want hardware encoding.


#3

ok. i will try a different version and see how that goes…


#4

I tried the binary tarball version and still having the same problem. I’ve pasted the console output from the shotcut program in a text file that is attached to this message. (tried to post the text output directly, but the forum keeps telling me i can’t post links, of which there are none)

shotcut.output.txt (5.2 KB)


#5

It looks like NVENC is broken on your system. Maybe it is not actually using the nvidia driver and using nouveau instead, or maybe you need to something in addition such as the cuda library:


#6

you are right, something was wrong with my nvenc. i was and still am using the nvidia driver, any other programs using the GPU seem to work just fine. but a recent kernel upgrade prompted me to re-install the nvidia binary driver again, and now shotcut can detect the hardware encoding capabilities. so, obviously, something was wrong with my setup; not exactly sure what it was, but the re-install of the nvidia driver seems to have fixed it.

thanks for your help!