WEBM VP9 clip not showing alpha

I am not able to import a VP9 clip with alpha.
(nor to export any movie containing alpha)

png works well, however, alpha seems to be ignored and
shows only plain black. I attache the file. It comes from this
discussion from another forum since i was not able to make it.

Please help

test_alpha_fire.webm.zip (126.1 KB)

OSX 10.13.4
SHOTCUT 18.05.03 (GPU processing disabled)

WIN 10 Pro Shotcut 18.05.08
I imported the test_alpha_fire.webm video into Shotcut successfully. Added a Chroma Key filter to it to remove the black and it plays in Shotcut.

However I cannot export it. Tried 6 exports and all failed.


An hour later I converted the webm VP9 clip to mp4 added a Chroma Key filter to it to remove the black and exported successfully with the default export.


The Chroma Key is just a workaround. In this case it works, but I think the clip should just behave like a PNG with alpha. There should be no need for for a Chroma Key.

I’ve routinely created .avi files in Xara Designer’s animation module and exported them with alpha and they import with alpha intact into Shotcut.

Without the Chroma key the clip will have a black background.

The clip does not behave like a png with alpha. I put the clip in Kdenlive and it still needed a Chroma key filter. And the Kdenlive render to webm failed.

Rendered to mp4 and it worked.


With Shotcut you can also use the Track blend mode add or screen to remove the BG.

Maybe one of the developers will take a look at the test file you submitted and figure out why it’s not exporting in Shotcut in webm fomat, but exports when converted to mp4.

The vp9 sample you provided has pixel format yuv420p, which does not include an alpha channel. If it did, it would say “yuva420p”

(nor to export any movie containing alpha)

This is advanced usage of Shotcut. There is no way to remove the black background in the Timeline, but you can work on a purely clip-based project and export it. After importing your webm and applying a chroma key filter to remove the black, you can export it with alpha by:

  1. go to Export
  2. choose your clip in Source player from the From dropdown
  3. choose “mov” from the Format dropdown
  4. click the Video tab
  5. choose 'qtrle" from the Codec dropdown
  6. click the Audio tab
  7. check Disable audio
  8. click the Other tab
  9. add “pix_fmt=argb” to the Other text box
  10. click Export File

This creates a Quicktime Animation, and there might be a way to output other formats with alpha, but this works.

This worked perfectly. Exported the file then brought it back into Shotcut and it has no black background.

But I tried to export with default export and webmVP9 and both failed.

Unable to reproduce

My bad.
When I export the mov file by itselt it works.

I put an image on V1 and the mov on V2 then the export fails.


Hmm. Previously, I tested with jpeg on V1 and the original webm with Chroma Key Simple on V2. Now, I just tested with the QTRLE MOV on V2, and that works for me too. I am using Windows 10 too.

EDIT: I just now reproduced it by placing the QTRLE MOV at the very beginning of V2. Previously, it was in the middle. I’ll see what I can do.

I moved the mov on V2 by one frame and it exports with the image on V1. Very odd.

Windows 10 SC 18.05.08

I found this bug in MLT and fixed it for next version.

1 Like

You guys are amazing, thank you!