Video won't play when exported

The video within Shotcut itself works fine, but whenever I export the video, it refuses to play, telling me that the file is unplayable (despite the fact that it is a .mp4). When it does decide to work, it only plays the audio and not the video itself. I did not change the settings, I’m using a Codec of libx264 and an audio Codec of aac. I have the latest version (20.09.27) and I’m using Windows 10.

This is my first time using Shotcut and I may be missing something.

Check if hardware encoding is enabled, if enabled then disable and try exporting again.


Hardware coding is off. I have exported the project three times now and it doesn’t seem to work.

Does the exported file play in Shotcut?
Did you export using a preset? If so, which one?
Did you change anything in Advanced? If so, what did you change?

No, I don’t use a preset as I have kept everything on my default settings. I have not changed anything in advanced and it looks like the project can play in Shotcut

So the exported video plays in Shotcut.
When the exported video mp4 file is in Shotcut, click on Properties. Can you share a screen shot of this panel?
Here is an example:
What video player/device says you can’t play the file?
Have you tried playing the file with VLC Media Player?

Apologies for not replying sooner. I managed to recreate the issue several times by exporting the file and exiting just before the jobs were completed.

Why would you intentionally stop the export just before it was finished?

Have you tried VLC instead of the included windows app(s) it has much wider codec support(that’s why @Hudson555x suggested it as well)

This topic was automatically closed after 90 days. New replies are no longer allowed.