Video slideshow looks blurry when using zoom out/in or pan from sides

Compared to the original version of the image which looks OK, when I use zoom out/in or pan from sides the final video result looks blurry.

Even thought I have set the export value to H.264 High Profile and in the codec I have increased the value to 75% still the exactly the same results after exporting the video.

Is there any way to preserve the quality of the image when doing zoom or pan?

I am using Shotcut 22.11.25
Video mode 720p - 29.97fps

I tried even with an image twice as big of the 720p - click the link to see the result.

I did zoom about 4%

I take it that you do your slideshows manually, meaning that you don’t use the Slideshow tool in the Playlist panel?

What version of Shotcut do you use?
What is the Video Mode of your project? (Example: 1980x1080, 30fps)
What are the original sizes of you images?

Can you share an example of an exported slideshow that shows that blurring? (use stock images if you don’t want to use your own).
A screen capture of your entire Shotcut window might help also.

Do you see that blur problem also before you export your project? Or only after exporting?
If you see it before exporting, increasing the quality in the export settings won’t remove blur.

I am using Shotcut 22.11.25
Video mode 720p - 29.97fps

I tried even with an image twice as big of the 720p - click the link to see the result.

I did zoom about 4%

That depends on how much zoom you apply to the images. If you zoom them to 110% for example, it shouldn’t be much of a problem. But you use more zoom, like 150%, 200% or more, you will start to see some blur.

You didn’t answer that question.

I did zoom about 4% click the link to see the result.

There is no blur before I open the image in Shotcut.

I’ll ask again…

Do you also experience that blur problem BEFORE exporting your project?

Do you see the same blur IN Shotcut in the Preview panel?

This is an important question. If the preview looks good, but the export is blurry, then you may need to tune your export parameters. But if the preview also looks blurry, then the blur is being added by the project filters or processing.

Yes I do see blur before exporting but it happens only after I apply the 4% zoom, prior to the SPR Filter there is no blur.

And there is only one SPR filter applied to each image, and not two? I’ve seen this problem before on images when there is a second SPR filter, but not just one.

The SPR filter performs interpolation - which will always cause some amount of blurring. But it can be affected by the interpolation mode. The interpolation can be changed for the preview player in the player menu. The default is “bilinear” in order to provide the best performance. But you can change it to higher interpolation to have better quality in the preview.

However, that setting only affects the preview. There is a similar setting in the advanced section of the export panel that you can also change:


You can try setting those both to “best” to see if that improves (reduces) the blurry effect.

I tried even this but I do not see any difference so far.

  • The thing that made the difference so far was this:.
  • When creating the video I thought to import an image twice as the size of the project in order to have more pixel density and more clarity.
  • But this was wrong, this created the problem.

When I tried importing an image the same size as the project {video 720 + img 720p} the problem got fixed up 85% I would say.

Even thought I tried to solve the problem somehow I am still open to listen to others advices.

This topic was automatically closed after 90 days. New replies are no longer allowed.