Video quality after generation

Hi guys,

I have generated my second video using Shotcut. This movie is a combination of short GoPro movies.

This time I have noticed a bit degraded quality comparing to original ones. I know I am not using lossless presets, but I have made a test: assemble just two videos withouth any filters or effects. And yea - the result has noticeably better quality.
Settings for both files are below (one the left side better one; on the right side worse one):

As you can see the differences are very small. They were both generated using the same preset (H.264 Main Profile) - with custom settings, for example 34Mb/s bitrate.

The longer movie and the one with worse quality has some effects like rotation (180 degrees), slowdown, etc. Can this be a reason for the degraded quality? I have tried to remove the effects, but no change in the quality.

Can this be fixed?
Is that a known thing?
I know this might not be enough information so I will happily provide the missing parts.

What is your Shotcut version (see Help > About Shotcut)?

Also, if you can post some comparison pictures that would also help.

1 Like

What is the nature of the videos? 34Mb/s fixed rate is not particularly high for 60fps video. If there is a lot of fast action or camera movement, the bitrate will get spread thin very fast compared to a stationary camera shot. The fast-moving video would look worse than a stationary shot at a fixed bitrate.

1 Like

Version is 20.04.12.

Bad quality frame:

Good quality frame:

As you can see the difference is quite big and this is surprising.

This is mostly nature, people moving, but not very fast (recorded with GoPro + gimbal). I have also tried to generate the longer movie setting the codec quality to 90% for example. The file size was much bigger: 2,77GB compared to 762MB for the one with 34Mb/x. Still the quality seems to be the same. If you want I can also share a frame of the 90% quality video. Here are the file settings just in case:
image

Hmm, 90% should be rock solid. It’s starting to sound like something else is wrong like the timeline resolution. Can you verify the timeline is not 720 and then getting scaled up to 1080 at export?

1 Like

Thanks Austin. I think you might be correct. Here are the properties of the timeline, I think:
image

In the ‘good movie’ it is 1920x1080, so the quality is better as well. But could that be changed automatically based on some operation, like filter, cut, edit, etc.? Or have I specified wrong settings while creating the project at the very beginning?

Do I have an option to change that now?

Indeed, that is the problem. You can change the Settings > Video Mode to 1080 and it should probably be okay so long as you keep the same frame rate. Ideally, the video mode should be set correctly at the very beginning of the project. The foolproof method is to set it to an actual profile rather than depending on Automatic mode to guess the resolution based on your first clip.

2 Likes

Did the GoPro movies that you used for this project have different resolutions?

1 Like

Thanks Austin. Indeed, I think I have set Auto mode at the very beginning as I though all my videos are 1080. Anyway, I already have 1080 in Video Settings:
video-settings

I have changed that to some other value and to the HD 1080p 60fps again so the timeline got reloaded.

Quality is excellent!

PS.: I think all my videos are the same, so that’s a bit wired.

Anyway, thanks guys for your quick help. Much appreciated!

By the way @apph, you should download the newest version of Shotcut because your version is a half a year old.

1 Like

Good deal! Glad it’s working. GoPro is actually 59.94fps if you want perfect alignment.

1 Like

you should download the newest version of Shotcut because your version is a half a year old.

Will do!

Good deal! Glad it’s working. GoPro is actually 59.94fps if you want perfect alignment.

Yea, guess while generating I can specify that precisely :slight_smile:

Be careful though, your version 20.04.12 supports the Text:HTML filter, while the latest version doesn’t. So if you are using this filter, at least finish your current projects before upgrading.