Video project keeps exporting at really low resolution

Hello everyone. I have have a video project that seems to export at 640x360 no matter what resolution I choose. The input source files are 4k resolution. I’m not sure what’s the cause here. I restarted Shotcut and it didn’t fix the issue. I also looked at other project files and they have the correct resolution. The main difference between tthis project and the other project I did is that this project is fairly long (about 40min compared to the 2min of other projects)

(For some reason I keep getting an error when I try to add a screenshot)

1 Like

Did you edit with proxies turned on?

Yes. I’ll turn off proxies to see if it gets better but I use proxies all the time

Still no change. I turned off proxies and preview scaling and I get the same result. This video is getting published in mid November so there’s no rush. If all else fails I can redo the entire project with a new file

Click on the top “track” called “Output” then the “Properties” icon. What does it display for Resolution?


My concern is that the bug got tripped where the proxy filename gets written into the .mlt as the original filename. I don’t remember which post had a good solution for that scenario.

The other possibility is to verify that the Export > Advanced panel does not have the “use preview scaling” option checked.

Look at the video file names that appear all over the window in various places when you have the project loaded. Do they look like your source file names or some random collection of letters and numbers (proxy file name)?
From the release notes for latest version 22.06:

  • Fixed repairing a project with Settings > Proxy > Use Proxy on saves proxy file paths into repaired project file.

Use preview scaling is unchecked

The video clips have the original source titles. I also deleted the proxy files

How do you know?

Right-click the export job (it does not need to complete and you can stop it), and choose View XML, save it, and upload it to a reply here.

Here is the XML file
export.txt (24.0 KB)

I got the hint because when I go to export and clicked Advanced, I see the resolution set to 640x360. I would change it to a higher solution, but the quality remains the same. Funny enough when I look at the codac info for the video in VLC, it says 3840x2160

Your Settings > Video Mode is wrong. Open the project and then change it. Then, use Save As to save with it a different name in case that went wrong. You might also want to check and change Video Mode when NO project is loaded to see what it will use for the start of your next project.

1 Like

Thanks changing the video mode worked!

The .mlt file shows 640x360 for the profile but 3840x2160 for the consumer. So when we do the Output test like @Elusien did:

…and we get the 3840x2160 response:

…does that mean Output is showing us the consumer, which is not necessarily the same as the profile/Video Mode? Meaning we cannot check Output properties to deduce project resolution reliably? What sequence of events causes profile and consumer to have different resolutions? The OP didn’t say they were overriding resolution in the Advanced panel to create 3840x2160, but it’s the only thing that makes sense to me so far, except for the Output properties part.

1 Like

Normally I to keep things set to “Automatic”, but after I saw that it was set to 640x360 I manually changed it to 4K.

I messed with the Video Mode in a previous project when I wanted to create a square aspect ratio, but I didn’t think it would follow into the currect project. Hope that helps

No, it means they did something wrong like not closely following directions and looking in the wrong place or using the wrong project.

It doesn’t, and your 640x360 video is not a square aspect ratio.

Oh then no idea lol

Thanks for the explanation.

This topic was automatically closed after 90 days. New replies are no longer allowed.