Video mode "automatic" setting does not use source resolution

What is your operating system?
MacOS 13.5.2

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?
Open Shotcut, change video mode from a previously created custom size to “automatic”, import new file with different dimensions from custom. Result: timeline resolution reverts to custom settings every time


After some more testing, I discovered that I was not able to use any presets at all, it would switch to my custom setting every time. The only solution was to delete my custom setting

Are you using Settings > Video Mode or New Project > Video Mode?
If you are using New Project, the selected Video Mode is only used if you click Start. This can be misleading, but it is by design… because another user sees the frame grouping these options and does not expect the video mode to change until confirmed by clicking Start.

Ahh I see, I was not clicking start, I simply selected the setting and then added a new file. Thank you for explaining! Love your app

1 Like