Video is keep cutting


OS is Windows 10
I downloaded the 64 bit (GitHub) version 18.07
GPU Effects is not checked.
Video Mode is Automatic
Display Method is DirectX

So I put together two videos into one by cutting/ trimming and the total minutes comes out to be ~9:37 minutes. When I export the file as mp4 and save it onto my desktop it comes out to be ~4:20 minutes. When I play it parts of the video is missing. I don’t know what I am doing wrong. Please help!

Edit: I noticed when I click the ‘Source’ tab the video only goes for 4:20 minutes, but the ‘Project’ tab is 9:37 minutes. I can’t seem to edit the time duration. How do I change the Source tab time limit?

Hi Logahn

Have you changed anything on the video mode after importing the clips?
I’m just guessing, that it could be related to the issue I described here:

Best regards,


I believe this is what happened.
You can export just one clip if you desire to, which might be what you picked. This is not set by default, you would have had to click on it.

This is what you’re going to want want for your whole video to be ~9:37. This setting shows by default.

When you clicked on the Source tab, it shows you the last file you opened up.