Video is already much further at the start

What is your operating system?

Windows 11

What is your Shotcut version (see Help > About Shotcut)?


Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

10 days ago I posted this:

"I’ve been using shotcut for years now and this never happened before. I’ve edited a gaming video, exported it, and it went fine. The video was normal in my computer files. Then I uploaded it to Youtube (3 times to check if it really wasn’t my fault) and the intro image (an image of the game name) was gone. The intro audio was still there, so the gameplay just started on the first second while my intro audio was playing. So when the intro audio was over, the gameplay was already much further than it should be. It’s really weird because in my computer files the video is perfect. It’s just after uploading it to YouTube.

So why do I think it’s a fault of Shotcut?

Yesterday I tried editing another video to send to friends on Whatsapp web. The video was totally fine after exporting. Then I send it on Whatsapp and it was just the first frame for the first 30 seconds.

I have no idea what went wrong, does anyone have an idea?"

Someone responded and said that I should turn my hardware encoder off. I did, and then it was normal again. But now 1 video later, with hardware encoder turned off it’s still the same. I posted this here because I don’t think I will get another response on that old post. Can someone help me?

log file.txt (34.1 KB)

1 Like

There is not enough information. You should do some troubleshooting and provide information to improve the bug report. What is the media format and its properties of what is missing? What happens if you edit out the part that was included and export (you do not need to save it that way)? How are you exporting? Turn off hardware encoder if it is on and use the default export settings without changing anything. These are just some examples. Maybe you can think of more.

Windows 10
I too am having almost the exact same problem. Running version 23.05.14, but bug might go back a bit further. If I load a video (mp4 format), then immediately export it, making 0 changes or edits, I’m finding the first few seconds of the video (~2:04 min of a movie (2:49:17 length) I’m trying to normalize the sound on) is missing. However, the sound isn’t removed. This causes the video and sound to be out of sync.

Watching the video in shotcut after loading it to the timeline, everything is normal. It’s only on export I can see/hear the problem. I’ve tried doing a reset of shotcut’s settings, but that didn’t change anything. I am using hardware encoding (h264_nvenc). Will try again with encoding turned off.
missing_video.log (3.7 KB)

Does it still happen if play the exported video in Shotcut? What created the file MyMovie - Full Movie.mp4?

The original was something I downloaded from youtube. No idea what created it. The original plays fine (except youtube doesn’t normalize the sound, so it’s all over the place). Original plays fine in VLC too.

Export, with hardware encoding, plays fine in shotcut. It does not play fine in VLC (my default), Movies & TV, nor Windows Media Player. Interestingly, each plays the video slightly differently. VLC, as I mentioned, cuts off first 2:04 of video, but not sound. Windows Media Player doesn’t show any video at all (original, pre-shotcut export plays fine). Movies & TV is the worst of the 3 because it shows no video for the first ~4 minutes, then just frames after that if you seek, although sound is fine.

I did another export with hardware encoding turned off and all 3 play it just fine. So OP was right. Bug has something to do with hardware encoding. I’ve downloaded an older version of shotcut. Testing now with hardware encoding turned on. Will update when it finishes.

Update: Using shotcut version 22.12.21,using the hardware encoding (h264_nvenc), the export plays fine in all three non-shotcut programs.

Okay, I will try to use the older version

It worked. If you have this problem install version 22.12.21.

This is a duplicate of

Testing with 23.05.14, and using the hevc_nvenc hardware encoding still produces the corrupted file.

Graphics card: NVIDA GeForce GTX 1060 6GB.
Driver: NVIDA
OS: Win 10 Home, 22H2

More experiments found an alternative work-around. Using version 23.05.14, if you set BOTH the hardware encoding to hevc_nvenc in the hardware encoding and in the Codec tab of Export, the resulting mp4 plays fine. Setting the encoding in hardware alone doesn’t fix the problem.