Video-in-Video does not work


#1

Hey Guys,

I am currently working on creating a LetsPlay video. For that, I want to include a facecam on my video so people can see my reactions. I have tried to implement it with the “Size and Position” filter.

However, every time I try to do to that it does not work properly.

So, when I use the presets like “bottom left” or “top left” or others it works fine but it just takes up too much space of the picture (see 1st screenshot:

Then, I want to resize but this is when it gets really weird. I tried to change the size to e.g. 320x540, then the box goes to the top left but extremely small (see red circle in top left on 2nd screenshot: http://www.bilder-upload.eu/show.php?file=cdeb68-1518353919.jpg ).

Then I go to the box with my cursor and try to stretch the video to resize it with the cursor, not with the filter settings to the left. But then the video gets lost completely and the filter settings take up really weird numbers for position and size (see 3rd screenshot: http://www.bilder-upload.eu/show.php?file=d3769f-1518354048.jpg ).

Now the video is lost somewhere in the program and I have to start all over again, but there is no way I can make it as good as it is shown in the youtube link above.

Thank you so much for your help guys, it is much appreciated.
Have a nice day.


#2

Which version of Shotcut??
If not the latest, install the latest, because I have no problems here with PiP under Windows10 64bit.


#3

I have 18.01.02 under Windows10 64 bit. What is PiP?


#4

Picture in Picture


#5

Ok. So it does not work for me
. :frowning:


#6

I have same problem.
Not sure is this is related to different file formats ?
My current setup is a .BDMV as the main footage and a .MP4 /h.264 as the overlay + additional .WAV audio track.
My overlay/PiP does not scale and position as shown on the timeline.

Did you find a solution ?


#7

Not sure I follow that statement. Timeline has no scale and position, only tracks with clips.
Can you supply a screenshot?


#8

Thank you for your response.
Poor choice of words, sorry.
I have 3 tracks:
Main footage: Video track 1
Overlay: Video track 2
Audio track: Audio track 1

When I apply the size/position filter to the overlay. I can preview it when I play the project (timeline) Looks fine in lower right corner.
When I export it to a final file, the size/scale and position is off.
The size is too big, and offset, off-screen to the right, clipping much of the visible video.

I’m not at my primary computer, will provide screenshots when I get home.
-Bo-


#9

Probably because the wrong initial video mode is set. (Settings>Video mode)
The way I work [generally] is to set the video mode to ‘Automatic’ before importing any files, this causes Shotcut to set the mode resolution/fps etc similar to first file you import. So make sure it’s a video file with the properties you want.

I’ve used PiP many times and it’s always worked out just fine.


#10

If you have changed the language to German, the presets in the Size and Position filter will appear in German and in English (even if you change back to English, both languages appear in the presets).
When you now choose the english preset e.g. “top left”, it will come to the problems you’ve described.
So choose the german preset “oben links” it will work properly.


#11

Just returned from vacation :slight_smile:

I tried your “Setting->Video mode” trick but did not help me, actually it got worse.

However: When I set the Video mode to the same as the intended export. (1920x1080 25P) then it works flawless.
I consider my case resolved.
Thank you for your kind support.
-Bo-