Video exported is different from video in timeline

I apologize for my bad English. I would like to report a bug in the software version 22.03.30.
Basically the exported video is different from the edited video in the timeline.

If in the timeline I make a cut in a video track, in the exported video I find some frames played twice near the cut. The result is that, for example, in the timeline the video track is 50 seconds long while in the exported video it is 55 seconds long. This also leads to a mismatch between the different video and audio tracks which appear correctly in the timeline but when exported do not match (subtitles in the exported video appear where they shouldn’t be, due to the fact that the main video track edited in the timeline, in the exported version of the video it is longer).

This is not a single video issue but it recurs on all videos (about 350) that I have edited in the past if I try to export them again.

For now I have been forced to download the previous version of the software (portable version) with which everything works correctly.

I hope I was able to make myself understood.

Without steps for someone to duplicate, it will be a bug that would be hard to fix.

It sounds like you have a mismatch of Video Mode FPS, to Source Video FPS. But this is all an assumption since you have not provided any specifications for your project.

There was a change in locale (numeric string) handling that could have affected projects made before version 19.06.16 especially on Windows. What is your operating system? And what are some of the Shotcut versions in your project files? You can find the version used at the top of the project XML file.

What is the frame rate of your source clips? I wonder if they are variable frame rate.

Shotcut version: 22.03.30

My system:
Intel(R) Core™ i7-4700HQ CPU @ 2.40GHz 2.40 GHz
16,0 GB (15,9 GB utilizzabile)
Sistema operativo a 64 bit, processore basato su x64
Windows 10 Pro

Basically I edit 2-4 minute cooking videos recorded with my google pixel 4a.
I load 1 to 10 clips in the playlist and in my projects I always have:

  • a video track with clips inside
  • a video track for subtitles
  • a video track for watermarking
  • an audio track for the soundtrack.

Basically my editing consists of cutting (or speeding up) the parts I don’t need of a clip (inserted in the video track). The problem is that in the timeline the video appears edited correctly but in the exported video I find very short clips (half a second) repeated 2 times. This leads to an exported video that is longer than the video in the timeline.

The funny thing is that a project made entirely with version 22.03.30, if I export it with the previous version, it shows correctly. If I export it with the 22.03.30 I have the problem.

I believe the source clips are variable framerate. When I import them into the timeline, shotcut asks me if I want to convert them (I always ignored them and it worked correctly, and still works correctly in previous versions)

Then, I think this is the problem because smart phones typically record variable frame rate, which is not reliable for editing. In Properties you might see a “variable” indicator next to the frame rate. Variable frame rate detection is not reliable, but if you see a very strange number then it is also a sign. You need to use Properties > Convert on them to make them reliable. We upgraded our most important library FFmpeg to a major new version, and the behavior of variable frame rate is likely going to be different. We will not be downgrading that library, but we do upgrade it on every release. (Each upgrade is not typically a major release).

I apologize but with my bad English I didn’t understand very well. Is this something that will be resolved with the next versions or will it remain so?
In that case, for my way of working, it is better for me to use an old version of the software. By producing 3 videos a week I need to minimize editing time. With my computer I have seen that converting each clip takes quite a bit of time (and hard drive space). Unfortunately, the smartphone is the most practical way I have to film cooking videos.
Anyway thanks for the help and the great work done on this nice software

I am not going to do anything directly to fix or improve this in future versions, but it could get better as FFmpeg is upgraded. You can stay on the older version and then test portables of future releases to see if it has improved.

I guess I have the same problem:
Always use Shotcut portable.

22.03 + 22.04 can’t export slowed down clips.
In the editor everything is still ok, but after export only white clips.

Until 22.01. the complete movie including slowmotion is exported correctly.
So i can edit with 22.03. + 22.04, but have to export with 22.01. :roll_eyes:

Almost all my badminton instructional videos show areas in slow motion.
Cause i use shotcut portable, i can reproduce this (bug/error/problem?) very easy.

I tried to take the folder from 22.01. to 22.04.:

Does not work. Again white slowmotion-clips.

Now i tried to take the ffmpeg.exe, too.
Does not work. By start of shotcut some errors, that find no av…dlls

Now i took all 4 av…dll + avutil-56.dll from 22.01, and shotcut starts.
But if i open one x.mlt, it shows invalid in the player-window.

What folders and files i have to copy from 22.01.30 to 22.04.25, to only change ffmpeg?

Make sure you have version 22.04.25

I´m sure to have 22.04.25. :nerd_face:

Is there really no (sorry, not now) solution?

No, you cannot change the ffmpeg version. The app and library versions are linked together.

I now have the same problem as described above by Martinieffect:
A video from 2018 (with variable frame rate) looks perfect in the preview. Cuts of a fast-moving badminton player are barely visible.

If I then export this mlt (6 cuts = 7 clips) with each SC newer than 22.01 (tested with 22.06 + 22.12 + 23.04), frames are added to the cuts. The exported video then clearly lags in the editing areas.

Only this works:
If I export with SC 22.01, the exported video looks just as smooth in the editing areas as in the preview in SC.

Because I did not find the solution to this problem for 2 days, I converted the source video with SC edit friendly.
But this did not help in 22.12 + 23.04.

I suspect either SC newer than 22.01. or the included FFmpeg have problems with some video files from older smartphones (e.g. 2018).
Since I’ve been using newer smartphones, I haven’t noticed this editing problem. No matter how new SC and the FFmpeg it contains are.

Here is the mlt
1min - Offensive im Vorderfeld 02 23.04 SP light saturation colourgrading without names.mlt (16.9 KB)

I tested with the project you provided, and immediately I found a problem: it is saving the XML with the wrong locale:

<mlt LC_NUMERIC="de_DE"

instead of


Notice the decimal separator is different. So, at some time the numeric locale handling broke. I will look into this.

Update: This is weird. I put my Windows into German language mode and region, and I am unable to reproduce the bad XML. The only way I think that could happen is if I use version 19.04 or older, which is the last version where it was supposed to be making a locale sensitive XML. Are you working by starting with a very old project and saving it with a new name? Start a new project with a recent version 22.12 or beta with at least one clip in the timeline and view its XML regarding the above, or share it here please.

That’s exactly what I’m doing a lot at the moment.
The following reason:
Since about 2015 I have been using SC (always portable) to edit badminton tutorials.
These could always be used 16:9 and unlimited duration for youtube.

Since a few weeks I have an Instagram account.
The videos for Instagram and youtube shorts should preferably be in portrait mode or square and with a maximum duration of 1 minute.

So I use some old SC projects and change from 16:9 + long duration to 1:1 with max 1 minute duration.
To use new features (e.g. Glaxnimate, Text:Rich), I then edited old SC projects (e.g. 2017) with new SC versions (e.g. SC 22.12 and newer).
Most of the time this worked, but sometimes with errors.

Is it possible to import only the crop marks without filters from old SC projects into new SC versions to avoid errors?
I would then create new filters.