Video export with wrong resolution

Hello all,

after a pause I’m working with Shotcut again but on a „new“ computer (MacBook Pro from 2015). Now there’s a problem that didn’t occur on the previous MBP from 2011.

I try to export a 1080p video from a project in which 4K videos (4096 x 2160) are rendered. The result is a 1080p video with a broad black margin; the info-window of QT Player displays “actual size: 1440 x 810”. What’s going wrong?

Clips are cropped at 256 px in vertical size, resulting 3840 x 2160 = 16:9.
I tried with several versions from 19.06.15 until the current version but it’s always the same result.

These are the export settings (default values except resolution and aspect ratio):
Use hardware encoder: disabled
Format: mp4
Resolution: 1920 x 1080
Aspect ratio: 16:9
Frames/sec: 29,970030 (as in original videos)
Scan mode: Progressive
Field order: none
Deinterlacer: YADIF – temporal + spatial (best)
Interpolation: Bilinear (good)
Parallel processing: enabled
Codec: libx264
Rate control: Quality-based VBR
Quality: 59%
GOP: 150 frames, not fixed
B frames: 3
Codec threads: 0
Disable video: disabled

Best regards

What is the Video Mode under Settings?

I’m not fully understanding this part. Do the 4096x2160 clips have a “Crop: Source” filter that crops 128 pixels each from the left and right sides? If so, everything should work as expected, assuming your video mode is 1920x1080.

Yeah – that was the right question :+1:
It was “Automatic”, but obviously this is not the suitable setting. Choosing “HD 1080p 29.97 fps” results in the correct resolution. Many thanks!

I did set 256 px on the left side – but yes, you did understand right :slight_smile:

That was the problem – the setting was “Automatic”. With “HD 1080p 29.97 fps” it works fine :slight_smile:

Unfortunately, the same problem occurs in another project despite the right settings.

Video mode is set to HD 1080p 29.97 fps.

The 1st clip (original: 4096 x 2160) has filter “Crop” with these settings:
Top 220 px
Bottom 140 px
Left 848 px
Right 48 px
This results in a resolution of 3200 x 1800 px, with an aspect ratio of 16:9.

The 2nd clip with 1920 x 1080 px is not cropped.

The exported video shows the same broad black margins as described above in my first posting. Now I’m really helpless …

That should work. Are there any scale filters on the track head or the Output track that are affecting it?

Sorry, I don’t know what a „track head“ or an „output track“ is. The project contains only one track, and this track has no filters …

But I found another strange thing: Clicking onto the “Master” area and choosing the “Properties” Tab above, there are displayed these values:

Resolution: 4096 x 2160
Aspect ratio: 4096 x 2160

Could this be the fault?

Oh … no wonder. Examining the mlt file I found in the 3rd line:
<profile description="automatic" width="4096" height="2160" progressive="1" sample_aspect_num="1" sample_aspect_den="1" display_aspect_num="4096" display_aspect_den="2160" frame_rate_num="30000" frame_rate_den="1001" colorspace="601"/>

Seems that I have to edit the mlt file …

OK … it helped to set the video mode to another value and then back to the target value. Though the profile tag in the mlt is not correct yet:
<profile description="automatic" width="1920" height="1080" …/>

… but finally the result is as desired :slight_smile:

This tells us you’re using a super-old version of Shotcut. “Master” was renamed to “Output” many versions ago. Fun trick: Filters can be placed on the Master/Output track which will affect the entire video. Useful for audio limiting or global video sharpening.

I’m surprised muted colors and shifted reds aren’t among the symptoms you’ve noticed. If the input files are 4096x2160, the colorspace probably needs to be “709” instead at a minimum.

1 Like

Exactly! :slight_smile:

That’s because the colors are ok …

Sorry … but I don’t have a clue about this. What does this value 601 (or 709) mean? And what have these values to do with the resolution?

They refer to color encoding standards. BT.601 is for standard definition video. BT.709 is for high definition video. BT.2020 is the successor of BT.709 used for HDR video. Each standard defines red, green, and blue to be different nanometers of light emission, meaning that colors will appear shifted and inaccurate if displayed with the wrong colorspace.

Try changing “601” to “709” and see if the colors look better than before. Maybe export a frame from both versions and compare them, especially a frame with a lot of red or orange in it. I can’t think of any common reason that a C4K clip would be encoded with BT.601.

Nothing. They only affect color interpretation.

Ok … but where? I can’t find an appropriate option in Shotcut. Should I edit the mlt file?

For an existing file, and for quick troubleshooting purposes, it’s usually easiest to modify the .mlt file directly. (Make backups of course.) Colorspace is defined along with resolution as part of the Video Mode under the Settings menu. This can be seen by doing Settings > Video Mode > Custom > Add. All of the built-in video modes like “HD 1080p 25fps” have a colorspace predefined with them as well, generally 709 for the 1080p and higher stuff.

Thanks for your Infos, Austin!

Meanwhile, I found these Infos under “Properties” (now in version 21.01.29):
Colour space: ITU-R BT.601
Colour transfer: ITU-R BT.709

True. I assume you’re looking at the properties of the Output track. But that panel doesn’t allow editing the values. That’s where editing the file becomes the easiest option.

In the case of this file, the colorspace is 601 and the transfer is 709. There is no reason those two values should be different like that. Colors are very likely to get shifted. It’s worth seeing if 709 looks better. But technically, it all depends on how the video was encoded, and it’s technically possible to do a twisted encoding like this. But extremely unlikely.

That’s right :slight_smile:

OK, I’ll try it …

Aah … sorry, I gave a false information! Actually, these values are not displayed under “Output” but in the properties of a video clip! And therefore they cannot be changed.

In the mlt files there’s no “colour transfer” value. And “colour space” is always set to 709. Everything in order :slight_smile:

This topic was automatically closed after 90 days. New replies are no longer allowed.