Video Encoding

Good evening.

I trust all are well.

Creating an account to post on the forum has been made necessary as:
ShotCut, essentially, stopped encoding. First started with encoding the wrong file type when selected as “Default” or “YouTube”. Basically, a blank space with audio. No video in the project. Before encoding, the video shows & everything is “peachy”. Encoding begins & the final product is 14MB, as opposed to 100-300MB usually. Re-installing is usually the fix. Not with my luck. Just realized I exported a test file to encode an hour ago & it’s still at 0%. Felt this post is necessary as my creativity is being put on-hold. Everything mentioned occurred within the last 24 hours. Restoring to a previous version of ShotCut could be the fix?

The only way to fix a bug is for others to duplicate the exact bug.
Going to need all information and steps how anyone could reproduce it.

As far as exporting with Default or YouTube settings, I was able to export to both presets yesterday with Shotcut 20.09.13 just fine without any issue.

1 Like

Make a super simple test:

  1. start or restart Shotcut (start with a clean slate)
  2. File > Open Other > Count
  3. Export > Export File
  4. enter a name and click OK

If it is still a problem, right-click the stuck job and choose View Log.

1 Like

Thanks! That’s what gets me, though. Those worked perfectly well. Yesterday. Could be any one of a number of problems. Might not even have anything to do with ShotCut. Went to a previous version: Export starts now, but timeframe is at (08:22:14). At 4% on a >2 minute video. Since export kinda works marginally better than before, might just need to duplicate the project, as you highlighted. Saved project might be corrupted, in some way. Thanks again.

Never occurred to me to check what a Job Log would look like on successful jobs. So, unsure if this should be empty. Done exactly as recommended. Still stuck on 0%. Anything I should check on my end? Thanks for the help!

Yes, you did follow the directions, and no this definitely wrong, weird! Close this Shotcut. Next, in Windows Task Manager Details view look for all shotcut.exe and qmelt.exe processes and kill them. Or, simply try again after a reboot.

1 Like

Hey. I trust you’re well. Thanks for helping out. Looked around, thought to check the log. Just a few warnings (just a few). In a last-ditch hope, I encoded a video. Left it overnight. Same result: No video. Just audio. Took around 6 hours to encode a 14MB/5 minute clip.

You have at least 1 filter on the Output channel.

To remove, click on Output then remove the filter(s).

1 Like

You are showing the application log. You should check the export job log by right-clicking the job and choose View Log.

Took around 6 hours to encode a 14MB/5 minute clip.

I suppose that is why it is appeared stuck at 0% - because it took so long to reach 1%. Still the export job log show should a little activity a few seconds after 0% appears. For example

[libx264 @ 0x7fda7c80c200] using SAR=1/1
[libx264 @ 0x7fda7c80c200] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
[libx264 @ 0x7fda7c80c200] profile High, level 3.1, 4:2:0, 8-bit
[libx264 @ 0x7fda7c80c200] 264 - core 160 r3011 cde9a93 - H.264/MPEG-4 AVC codec - Copyleft 2003-2020 - - options: cabac=1 ref=2 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=6 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=12 lookahead_threads=2 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=1 keyint=149 keyint_min=14 scenecut=40 intra_refresh=0 rc_lookahead=30 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00

Did you reboot as I had suggested?
I think most people who have an unexpected very long export time like this is because they are low on memory for the Shotcut project. Then, the system ends up swapping memory with the hard drive like crazy.
If you reboot, immediately start Shotcut and nothing else, and immediately start export you giving nearly all of your RAM to Shotcut. Again, do the simple Count test I mentioned in my first reply. Verify a simple test works before trying your project.

Thank you! Got the video out yesterday. If you’d ask me what the problem is & how I solved it, I would have no idea. May be that. I started the same project from scratch. It’s actually running more smoothly & more responsive than before. Thank you for your help.

Everything from “If you reboot…” I did, coincidentally. As you’ve foreseen, it worked perfectly again & even better than before. Thank you for being a better form of “troubleshoot” than any A.I would be. I trust you’ll continue to have a fantastic week.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.