Video black out when adding text

I’m on Windows 10 Home edition with Shotcut 20.09.13 (correction: 20.07.11).

This project I’m working on has a few video and audio clips. I have 4 video tracks - 2 for video clips, and 2 for text; and 5 audio tracks.

I’m making subtitles for the whole project, everything else works just fine, but when I got to the last video clip, adding text makes the video black out. And it happens only to the last video clip, and it doesn’t matter which text track I use.

The second to the last video clip is on video track 1 (let’s call it video clip A), and the last video clip is on track 2 (let’s call it video clip B). I used fade out and fade in for these two video clips.

To test this problem, I put a text clip in between video clip A and video clip B, video clip A would show just fine. But once it plays into video clip B, it blacks out.

I tried to turn off the fade in filter of video clip B, but it didn’t help. But when I moved video clip B from video track 2 to video track 1, all of a sudden the problem is solved.

This is kinda weird, so thought I should report it.

You should keep that project mlt file just in case this is a legitimate bug so if it is you can share it with the developers.

Did you have any filters on the video tracks or Output track? It would look like this if you had any filters on the Output track:

How convenient. Seems like I have the exact same problem.

Here’s my current project file: https://drive.google.com/file/d/1r-Vqx7iemCWWd-U93K5vveJsFnPGbdIw/view?usp=sharing
Problem happens at 1:07.

A screenshot of your timeline would greatly help.

This arrangement doesn’t present any issues.

@RickyRister what exactly is the problem?
I see you faded in on your top text.
This project is created with Shotcut version 20.07.11

If you apply a Fade In Video it will fade up from black.

Ok, here comes my screen shot. This bug, I believe is not caused by filters, such as fade in/out or what not. You’ll see in my screen shot, the problem persists even with NO filter at all is applied on ANY track in my project. And it happens not just to the text, but images as well. The solution is the same, you move the video clip down to a lower layer (or bottom layer) track, and all of a sudden, everything works fine again. (I made multiple screen shots, but this forum only allows me to upload one.)

Filters removed: text on top of video clip B

Problem solved when I moved video clip B down to video track 1:

Oops, the actual problem starts at 1:11.

I believe this problem was addressed in version 20.09.13, which you stated that you are using, but your screenshots do not reflect that. The main toolbar in the new version looks different than what showed.

Sorry, I was confused. The version I was on is 20.07.11. I updated to 20.09.13 just now. It seems the problem is solved in this latest version. Thanks!

1 Like