Video Becoming choppy when adding filters or 2nd video Track


#1

In version 18.11.18 when I add 3D text or a second video track the video and audio becomes choppy/laggy/frame drop like. Windows 10 PC.


#2

It will do that in the preview screen unfortunately unless your PC is mega powerful. There’s a lot of processing going on to show the video in realtime. It should be fine once it’s exported though.
You’ll see a very long thread on this forum regarding proxy files, which is a way of using lower resolution files in the edit to allow the preview playback to be smoother, but exporting using the full resolution files. I would give it a read if that idea interests you, but if you are using HD files then the more tracks and effects you add, the more choppy the preview playback will be.


#3

Can you provide me a link to that thread? I have exactly the same issue. I upgraded from 18.09.16 to 18.11.18 as I read in one of the forums that this problem has been fixed.


#4

Hi ,
Having gone through the other threads, I figured what I needed to do. I was editing a video that has two tracks. I use one of the videos as a pop out video. I was using the Size and position filter for this. The 2nd track had some background image. I had to turn off all the filters and the audio became smooth as the original video clip.

On a related note. I have an issue with inserting a video track. When you insert a video track it always inserts above the video track that exists. I want the new video track below the video track that exists. The pop out feature does not work otherwise. How do I do that?

Thanks


#5

Select the track header below the existing video track.

image

Right click, select Insert Track.

image

image


#6

Thanks Sauron. This will work when you have two video tracks, one of which is being used. In my situation, assume that you have one video track and you have video clips edited on that track. Now, you want to add a track but that track has to be below the track that has several clippings. Shotcut will insert the new video track above the video track filled with clips and not below. That is my issue. As a workaround, I always create two video tracks in the timeline before I start doing any editing in my project.


#7

When you have only one video track you can’t insert a track below it. That’s just the way it works. There’s a way to rearrange the tracks but that requires you to edit the mlt.


#8

I sometimes need to insert something under a track (quite often now I use chroma key much more) so I frequently leave V1 blank and work from V2 upwards. If I get to the end and didn’t need it for any reason it’s only a couple of button presses to remove it.
On your current project, I can only suggest you add a track above and manually move everything up to the new track.