Very serious frame drop

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)?
I don’t know the detailed version, but it’s the latest version at this point

Can you repeat the problem? If so, what are the steps?
I don’t have a problem in normal situations, but with zooming in, there is a very severe frame drop. This is a very serious bug that has adversely affected editing, and this has resulted in a significant increase in editing time. I didn’t feel anything wrong with anything other than zooming in, but I think it may have happened to other effects as well
I need help. This issue has been happening since I first installed this app and it hasn’t been fixed since then, so I reported it
This problem only happens within the application. When I finish editing and check on the app, I get a frame drop, but when I save the video and check it from the outside, the frame drop doesn’t exist and plays normally. I’m always complaining of discomfort because I save it for review and it’s difficult to fix it immediately


LOG.txt (47.4 KB)

Welcome!

It looks like you have added very resource demanding filters (HQN3D Filter) to your video. There is no CPU which can play this smoothly on the fly.
You can work with proxy file, lower the preview resolution or simply divide up your video editing into two projects. One project does only set up all the filters for the clips and you use the second project to cut the filtered and exported clips from the first project.

Thank you for your reply. Then do you know how to disable the filter? I’ve never heard of the filter

I 've seen this in your log.txt:
[Debug ] FilterController::loadFilterMetadata reading filter metadata “hqdn3d” “meta.qml”
[Debug ] FilterController::loadFilterMetadata added filter “노이즈 감소: HQDN3D”

The filter is a noise reduction filter which also uses past images to process the output.
You can add some kind of motion blur to your video, this is very resource demanding.
Also the other filters sum up in the preview player and the encoding export time.

Your answer was very helpful. Lastly, I want to ask you a question, is this filter essential in the process of processing motion blur? If it’s correct, I’m also curious about how motion blur doesn’t cause problems

I did not find any other filter which can add motion blur in Shotcut. This filter is not designed for motion blur but it does produce some motion blur as side effect.

I am 100% sure that every filter which is capable of motion blur is very time consuming on CPUs.

Background info:
Motion blur is wanted for videos lower than 50fps because than the video looks smoother without getting visual blurred in playback. Even filmmakers add motion blur to videos with 50fps of higher with the 180° shutter rule.

Those log lines means that Shotcut has found and added that filter to its filter chooser menu. It does not mean that it was added to any clip. But yeah, HQDN3SD is slow but also is “zooming” as reported. In any case you are correct about some filters being demanding on CPU.

Basically, this topic is in the FAQ under “Why Is my shotcut playback so laggy.” There are some pinned posts at the top of the forum telling you to check the FAQ. It is also related to some info on the web site FAQ page. In addition to the remedies mentioned, this frame-dropping behavior also depends on Settings > Player > Realtime (frame dropping). Turn that off, and it does show every frame but then your audio might become more choppy on sections that require heavy processing (because it is waiting for video to catch up).

I used to go through all the FAQs in the past, but I completely misunderstood the meaning of that title because I use a translator. Thanks to you, I have greatly improved my problem. Thank you for your response