Version 18.11.18 crash on Debian Linux


When I run shotcut version 18.11.18, it crashes. I used the 64-bit Linux portable tar. It sounds a problem of DRI version that is not compatible. Note the previous shotcut version (18.11.13) does not crashed.

My configuration:
Debian 9.6
libgl1-mesa-dri version 13.0.6-1+b2

$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD CAICOS (DRM 2.49.0 / 4.9.0-8-amd64, LLVM 3.9.1)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.6
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 13.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Messages from shotcut (I run the script shotcut that is in the folder
[Info ] Application::Application> Starting Shotcut version 18.11.18
[Info ] Application::Application> Linux version
[Info ] Application::Application> number of logical cores = 2
[Info ] Application::Application> locale = QLocale(French, Latin, France)
[Info ] Application::Application> install dir = “/home/patrice/logiciels/shotcut-linux-x86_64-181118/Shotcut/”
[Info ] Application::Application> device pixel ratio = 1
[Debug ] ShotcutSettings::log> language “fr_FR”
[Debug ] ShotcutSettings::log> deinterlacer “onefield”
[Debug ] ShotcutSettings::log> external monitor “”
[Debug ] ShotcutSettings::log> GPU processing false
[Debug ] ShotcutSettings::log> interpolation “nearest”
[Debug ] ShotcutSettings::log> video mode “”
[Debug ] ShotcutSettings::log> realtime true
[Debug ] ShotcutSettings::log> audio channels 2
libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver:
libGL error: failed to load driver: swrast
[Debug ] MainWindow::changeTheme> begin
[Debug ] MainWindow::changeTheme> end
[Debug ] MainWindow::MainWindow> begin
[Warning] <> Unrecognized OpenGL version
[Warning] <> Unrecognized OpenGL version

Thank you for support.

The only change I see between 18.11.13 and 18.11.18 that could make a difference is that we now bundle the VAAPI drivers from /usr/lib/x86_64-linux-gnu/dri/* and then set LIBVA_DRIVERS_PATH in the launch script to locate these. Can you please try to comment the export LIBVA_DRIVERS_PATH line and see if it works?

Thank you for your answer. But unfortunately, it does not work. I had the same error messages. Same error messages with the last release 18.12.23.

From 18.11.18, I read that the Linux build is based on Ubuntu 16.04 which uses libgl1-mesa-dri (11.2.0-1ubuntu2). Debian 9.6 uses libgl1-mesa-dri version 13.0.6-1+b2. May this difference explain this problem ?

Thank you for your support

Ah, yes, that is another change as well! That probably explains it. The change was made to facilitate support for VA-API.

Is there anything specific we can do to fix this? I’m running Ubuntu version 17.10 and am having the same problem. Currently using Shotcut version 18.11.13 and it works fine but I don’t want to get left too far behind.

Ubuntu 16.04 uses libgl1-mesa-dri 18.0.5-0ubuntu0~16.04.1. If you install libgl1-mesa-dri from the debian backports, shotcut 181223 will run:
sudo apt -t stretch-backports install libgl1-mesa-dri

Thank you for the feedback, all.
The build scripts gathers all library dependencies recursively while excluding things primarily based on this list from AppImage plus a few others:

Here is our equivalent to that:

The libgl1-mesa-dri package only contains DRI drivers, and we do not include any of these in our package. I do not know a whole about this part of the graphics stack. There is some library that needs to load these, and the version we supply does not appear to be happy with the versions on your system. Thus, perhaps we can identify the library and exclude it. Looking through the contents of, I am suspicious of libdrm_*.so.* especially given the note around in the AppImage excludelist.

Can some of you please remove your workaround, rm*.so.* and test it? If this works, I will remove these from the next build. Thank you!

I’ve just tested your suggestion (rm It solved the problem. Shotcut starts fine now. Thank you for your support.

1 Like

My shotcut also starts just fine after removing those files.

1 Like

OK, thank you. I changed the build script to exclude the libdrm drivers. That will be in the 19.01 version.

The v19.01 is available with this change, includes AppImage:

I’ve just tested the 19.01 beta using the package shotcut-linux-x86_64-190119.txz. I confirm the issue is solved. Thank you.

Hi !
I tried to update recently the Shotcut version I used (64-180702 on a Linux LMDE 2 machine), rather surprised by the number of updates published I missed, and I downloaded the current latest one (64-190127). After extracting, the program didn’t execute.
Then I downloaded the version next to those I currently used to find the most recent version that will execute on my machine : I found that 64-181113 is OK and that 64-181118 is not. So I found this post which seems to address the issue I encountered.
I tried the cure proposed by shotcut in 7/12, but failed to make 64-1118 execute, which is not so surprising as 64-190127 didn’t execute either.
LMDE2 stands for Linux Mint Debian Edition 2 (Betsy)
Kernel version 3.16.0-7 -amd64.
I am satisfied by 64-181113, but it could be interesting to find why more recent versions don’t execute.
Thank you,

This topic was automatically closed after 90 days. New replies are no longer allowed.