V21.02 BETA is now available to test

@brian, @shotcut:
Still not working for me. Seems to be erratic as well.
Here’s what I did. (Windows 10):

  1. Deleted originally downloaded SC 21_02 folder, re-downloaded from github, unzipped to desktop.
  2. Double-clicked shotcut.exe. Same problem - SC logo appeared then disappeared. Then nothing. No mention of SC in task manager.
  3. Tried again - worked - SC opened OK.
  4. Closed SC. Tried again. No luck again, step 1 happened.
  5. Tried again several times. Step 1 every time. No SC.

This has never happened before to me with portable SC folders.
Weird…

1) With the Size, Position & Rotate filter when you have the Size Mode to Distort and you zoom in tight (like 300% or more) then press the default button, it doesn’t go back to the position it was before the zoom in. It’ll throw the image somewhere else.

2) If the name of a file is long, when you go to Properties the clip’s name appears with “…” at the front. If you then from the Properties tab simply click away to change the focus from that tab to another panel like the Timeline, the name of the clip gets changed with the first part of the name cut off with “…” at the start instead. Demo.

3) On my personal layout I have the Keyframes and the Jobs panels as low as they can go but every time I restart Shotcut it defaults it to a taller height.
My Keyframe layout

Keyframe layout after Opening Shotcut

My Jobs layout

Jobs layout after Opening Shotcut

4) Make sure Ripple All Tracks is on. Have two clips one on top of the other. On the bottom clip create a transition. On the clip above, split the clip anywhere before the transition below. While still on the clip above, go anywhere after the transition and ripple trim the clip in (Shift+I) so that the transition below is deleted. Now undo. On the track below the clip that was to the left of the transition will be deleted. Demo.

@DRM None of these issues will be addressed for this release.

Should I make separate bug threads for any bugs I post on a beta thread that you decide not to address in that beta?

Yes as these are not specific to this version.

Is this repeatable and a regression since a recent version?

This problem is fixed for the release. I worked with him in a private thread to solve it.

2 Likes

This was in regards to the Opacity smooth keyframes @Hudson555x reported. Basically, I ask that beta testers help a little further by qualifying their bug reports a little more. Many of bug reports we receive on the beta thread are for old or minor bugs. Again, the beta test period is mainly for finding major regressions and critical blocking bugs. If it helps, think of it as a release candidate instead of beta.

I reproduced the opacity bug, and it is not new. I also have a fix, but I am not going to put it into the 21.02 release. The workaround is to either using only linear keyframes as you have done or to to change only the second keyframe to linear so that the top is flat and does not go over 100%. The interpolation algorithm that all smooth keyframes uses does not provide full control over the curvature. In this case, when the curvature exceeds the filter’s range maximum, the filter misbehaves.

1 Like

For Zip Files. Win 10 now defaults to placing a block on the file under File properties. I have noticed this on everything I download. Extraction tool in Windows will still allow you to unzip, but continues to block the running program from starting. Just a thought. I am getting ready to test this release tonight. Thank you guys

I’ll delete above post, and work on a bug report post.

The problem is I have no idea whether or not what I am reporting on is an “old” bug or not. When you post betas, I try to be more aggressive with my usage of Shotcut than the periods outside of beta releases to find bugs. I report on what I find. I’m sorry but I don’t have the time to reinstall previous versions to check if every bug I found on a particular beta was happening before that beta. I take enough time out to find bugs and try to reproduce them before then taking the time to document it as clear as I can. And that includes the fact that I have come across bugs that took a long time for me to find how to reproduce like the one I did recently about the 1 frame transition.

Also, your opinion of what is critical is different than mine. I would classify that undo bug I reported here at #4 as critical because when I found it, it ruined work that I was doing and I had to redo a whole section of the timeline. But you don’t think it’s critical. That’s fine but I found it when I was testing out this beta which is why I reported it.

1 Like

If you are running a beta, you really should keep at least one older version around for your own good. OK, I cannot keep everyone from reporting as much as they want, but I can no longer try to reply to everything reported in beta announcements. I will if I need more information. We do not have anyone dedicated to managing information and communication, and things will get lost.

Do you know from memory what bugs are new to the beta or do you test the bugs reported in the betas on previous versions to see how far back they go?

A simple comment like “out of beta” would suffice to know that a particular bug is not going to be addressed in the beta period.

1 Like

@brian, on the Each Playlist Item feature, for the date option I know the numbers before the dash are the date but what are the numbers after the dash represent?

EDIT: Never mind, I see now that it’s the time.

1 Like

I was having the same issues that you are experiencing, in my case I updated my version of JACK on my system as I noticed that have included components from them.

From release notes.
" * Upgraded JACK audio library on Windows to version 1.9.17."

His problem was due to JACK as well, but I made a change for the release that he tested. Now it will load the Shotcut local DLLs before attempting the system folders to avoid an incompatible version. In the past this has also affected the SDL DLL which was in a system folder for some reason for some users.

1 Like

5) Go to File>Export Frame and click it. When the file explorer to export the frame comes up press cancel. Go to File>Export Frame again and click it. After you cancel again the file explorer to export will automatically spring up another time. For as many times as you click to cancel to export a frame in one session the option will spring back up that many times.

Confirmed

1 Like