V17.11 Jerk-pause at clip points. Update button vanished. Button functions


#1

I’m a newby. I like Shotcut. I tried VSDC but it was not as user-friendly. I did some deeper investigation and determined that VSDC was Russian government sponsored and that sent me looking. I found Shotcut.

The forum is very helpful and it helped to find out that the program is in development. Many thanks to the developer(s) for Shotcut’s impressive features and for giving it away.

Bugs??

  1. I compiled one multi-image video plus narration sound track, saved it, exported it (MP4) - using an earlier (2016) version of Shotcut that I downloaded from some third-party site. I then discovered that there are monthly upgrades. I dumped that version of the program off my computer and downloaded 17.11 -64 bit directly from Shotcut. Play back of my exported video had audio but a black screen, both with VLC and with latest version of Shotcut. The exported kml also lacked the video when I opened it in the new Shotcut version. So I started over from scratch with 17.11. Problem now is that there are brief pauses at image clip points. Both the timeline marker and the audio hesitates at the beginning of each clip. I review, nudge clip ends together with mouse and replay. Quick playback of the joined clips - no jerks, but then on full review of the product the jerks/pauses re-emerge. In attempt to remedy I clicked “Ripple all tracks” but that did not solve the problem. Is there a bug or what should I do?

  2. On my first assembly of the above video with the 2016 I added clips by dragging from the source-screen onto the timeline track. On my re-assembly edit I began doing that with the 17.11 and it worked for several clips but then would show a slashed-circle on a clip as the clip was dragged onto the track and it would not “overwrite”. I switched to using the plus mark button for appending clips and that seemed to work fine. But as described before, the video ended up with the jerks. Why the circle-slash null for dragging all of a sudden? Why the jerking at clip points, even when the plus button was used?

  3. On a second production, using only the 17.11 version, I frequently used the update button and also frequently saved as I assembled. No jerk-pauses at clip points. But now as I work again on the first production, the update (check-mark) button has disappeared. Why has it disappeared? What is affected by the update button and when should it be used? What does it do that is different from the save command?

I am using Windows 10.


#2

Did you export and the result has the pauses? If not, and you see this while previewing in the app, then the engine on your system and with your formats is not fast enough to seek to the starting point of next clips during realtime playback. However, export is another matter and does not need to be in realtime.


#3

Thanks… I had not wanted to export the jerky production but at your suggestion I did export and that solved the problem. The exported version playback is fine.


#4

Still wondering when to use the update button and how its function differs from Save?


#5

The only Update button that exists is at the bottom the Playlist panel and has nothing to do with save. The Playlist update button is for when you double-click a playlist item, make changes, and want to Update the playlist item with your changes. When you double-click a playlist item, you are really opening a copy of it. Instead of updating the playlist item, you could use the trim tools to select a different portion of footage and then Add or Insert it to a new playlist item. All of what I just wrote has nothing to with saving a project file. The Save button saves the project to a project file.


#6

OK. Thanks for explaining that. Another thanks for Shotcut.