V1 track shows up twice

hi. while editing my v1 track has somehow duplicated itself. i’ve suddenly got two v1 tracks, which causes issues while editing. i’ve no idea how this was enabled, hence i would love to get some help on how my video track has duplicated itself, what it means and how i can reverse this. thanks!

update: after closing my project and shotcut, and reopening it again my sequence is all messed up. the second v1 track is gone but all tracks on v1 have moved as the first clip has become very long. my sequence has gone from 18 minutes to 2 hours and 30 minutes.

version:
fbk_20200108202302_502x450

What version number of Shotcut are you using?

updated first post with version info.

this might be some sort of bug. every time i reopen my project i get a different result, and the first clip on v1 becomes a lot longer than it actually is. my entire project seems to have gone down the drain. trying to change the cut it gets all distorted on the timeline.

now, my project looks like this:

initially, v1 had the same length as the other tracks.

Did you download your version of Shotcut from here?

it’s downloaded through pamac manager. as i’m on manjaro linux / arch, shotcut is a part of the community pool of sw.

We can not support that shotcut build because we did not make it. Please try the portable Linux build from the shotcut download site and report back.

ok. now i’m using the portable tar version of shotcut.

fbk_20200109092003_502x449

reopening my project still is causing this weird extra v1 track to appear. i can play my project, however, if i try to move anything on the timeline, sound and images gets out of sync.

i tried exporting an edl of the project, hoping i somehow could start a new project and get it working. however, it fails.

[Error  ] <MainWindow::on_actionExportEDL_triggered> Uncaught exception at line 6981 : "TypeError: Cannot read property '0' of undefined" 
[Info   ] <MainWindow::showStatusMessage> "A JavaScript error occurred during export." 

It looks like your file might be damaged. It would be difficult to determine what damaged it. But you can try to fix it.

I would recommend:

  1. Make a copy of your “.mlt” project file
  2. Open the copy in a text editor
  3. Try to identify the elements in the file that are causing the extra track and delete the one that you do not expect
  4. Try to open the modified file in Shotcut

If you post (attach) the file here, someone might be able to help you try.

1 Like

the one thing i did in this project that i have not done before was selecting the option to separate audio from video on one clip. however, after i did this i did an “undo” to revert the changes. i’ve no idea if this damaged my project. i tried going back in time, to check if older saved versions of this project was ok. however, no luck.

i ended up having to start over again, from scratch.

it seems like a bug, so attaching the project file here if anyone is interested in looking at it.

buggyProjectFile.mlt (432.0 KB)

The hidden black background track got converted into exposed video track somehow. Here is my attempt to fix the project.
buggyProjectFile - fix1.mlt (432.2 KB)

1 Like

thanks a lot, dan. you fixed the project file!

i’ve no idea how this did occur in the first place though.