Using Text: HTML Overlay on a server

Hello,

I would like to start off by saying that this is a very neat piece of software and I am greatful to all the developers who have contributed to it. It’s really great to be able to edit videos on a free powerful software!

I made a video previously that had some clips with the Text: HTML overlay on using the WebVfx.js animation engine. I moved the entire project on a server and now when I try to further edit the video, the clips using the HTML overlay do not render (white screen). I have managed to narrow down the problem to the animation .htm files. If they are stored on my computer and reload them they work. When I try to load them from my server, they do not work anymore. I do not know if this is an easy fix but it would certainly be useful to be able to edit the video no matter where the .htm files are kept.

I am using the latest version of the software (19.12.31). The path to my video project folder on my server looks something like this: “\DS918\Video editing\ProjectName”.

Thanks in advance!

Have you moved all the files, including any Javascript (.js) files?

It is easier to use a browser for debugging, so try running the HTML in a browser and check the debug console (function key F12) for any error messages.

Yes I have, in fact it works perfectly well on a browser. It’s really in Shotcut that it does not work. I was thinking maybe it’s a path name issue?

Strange - Have you looked nto the shotcut log to see if anything is reported there? Unfortunately problems with HTML filters don’t often report any errors in the log, but you may be lucky.

Good idea. I went to have a look at the log and here is the error it keeps showing up:

[Error] <MLT> [filter webvfx] "plain:/Video editing/ProjectName/test.htm" Failed to create WebVfx ServiceManager

When in fact the real path should be as stated earlier: \\DS918\Video editing\ProjectName\test.htm.

Have you tried removing one of the HTML filters and re-applying it from its new position on the server? Does that work?
If so you could check the MLT file to see what the difference is and edit the other HTML filters accordingly (after making a backup copy of the MLT file just in case). Or just delete them all and re-apply them.

I have tried removing the HTML filter and re-applying it from the server and it does not work.

I’m sorry, I really don’t know what else to suggest. I haven’t come across this problem before, but then again I serve all my files from the a drive on my computer, I can’t think why moving them all to a server would be a problem.