User with a problem with Text filter

@lotusmoon posted this inside a different topic, so I reproduce it here:

Can anyone help. when I click on text no text comes up on the screen. . I do not get a text box with the time code to write anything in. I get everything else but there’s no actual box for me to write into. I’ve tried pressing every button and doing everything I can think of but still I don’t get the box to write in. Does anyone know how I can actually get a box to write in. Yours very frustrated

You need to explain more clearly e.g. which version of Shotcut you are using and the steps you are taking e.g. there are 2 text filters; Text:Simple and Text:Rich in the latest version, both of which work perfectly for the majority of users… It also helps to post a screenshot so people have a better idea (a picture paints a thousand words).

I suspect you are using Text:Rich, which requires you to type your text directly into the source player window, whereas with Text:Simple you type your text in the filter itself.


Thank you Elusien. in all the videos I watched a box appeared in the filter bit with everything else. but not on my version I had to click on the timeline clip and that put a line around where you view the video and I could type directly into that. Many thanks for taking the time to reply :))))))))))))))))) I only downloaded Shortcut a few days ago so am not sure if I am doing something different or the version is different.

Dear Elusien thank you for your reply I have sorted out the basics of doing text now thank you. but now a new glitch has started happening. I am put text into a video at 3 different places and the text from the central box is getting transposed on top of the text in the two other boxes I have no idea how to get around this. I have attached a screenshot

is it possible you could also help me with this?

It is better to do text filters as overlays using a separate track (V2 in your case). So:

  • Create a video track (V2).
  • Position the playhead on that track to where you want the text to start.
  • Use “Open Other” and choose “Text”.
  • Type your text.
  • Insert it on V2 at the playhead position.
  • Position the playhead where you want the text to end.
  • Grab the right-hand edge of the text clip and drag it to the playhead.

Then repeat this whole sequence for the 2nd and 3rd text overlays etc.

1 Like

La tête de lecture est sur 1 clip (1) Le texte de ce clip est affiché dans le lecteur
Un autre clip est sélectionné (2) Le texte de ce clip est aussi affiché dans le lecteur car le VUI du filtre (3) est actif.
C’est ce qui provoque les 2 affichages superposés.
Cliquez sur la croix (4) pour désactiver le VUI du filtre (3), vous n’aurez plus que le texte du clip sous la tête de lecture (1)

The playhead is on 1 clip (1) The text of this clip is displayed in the player
Another clip is selected (2) The text of this clip is also displayed in the player because the VUI of the filter (3) is active.
This is what causes the two displays to be superimposed.
Click on the cross (4) to disable the VUI of the filter (3), you will have only the text of the clip under the player head (1).

1 Like

Hi @lotusmoon, @Elusien and @Namna gave excellent replies but maybe this video would be worth watching also. Always best to put text clips on a separate track, as @elusien mentioned.


Thank so much that is really useful :slight_smile:

Thank you thats really helpful

Thank you all great video

This topic was automatically closed after 90 days. New replies are no longer allowed.