User interface problems on Ubuntu 18.10


I installed Shotcut on Ubuntu 18.10, but the user interface is not scaled correctly. I have a Full-HD screen, but can only see parts of the application. For exaple from the timelime I can only see half of it. I cannot move or resize the application either.

Font scaling is normal. I used Shotcut earlier on Fedora without problems.

Any tips what I can do?

You did not state your version or how you got it (for example, flatpak is different than our builds, which is going to be different than a distro build - welcome to Linux fragmentation). Try the new version 19.02 that has a newer version of Qt that might automatically adapt better. If not, the new version has new command line options to control high DPI behavior that might be affecting you.

Shotcut version is 19.02.28 that I installed via this PPA.

I tried the following options:

Now at least the Fullscreen mode is working okay. However, in the non-fullscreen mode the window is still too “long” and I am unable to resize it or scroll down.

Shotcut via Openshot ppa?

They are two different programs.

Hi, I just installed the version via the Snap store. Same problem. The windows is way too wide (that at least I can resize manually), but the window is also too long (that I cannot resize). So I cannot see the timeline properly, which means that I cannot use the application.

Running also Shotcut on a Macbook, there it shows correctly…

@chris_bachonline there is some confusion in your posts. We can’t tell if you are talking about Shotcut or Openshot and we can’t tell exactly which version you are talking about.

To be clear, in this forum we can only support Shotcut when installed from the officially supported packages downloaded from here:

For help with OpenShot (not Shotcut) or packages from other sources, you will need to reach out to those specific package providers.

That is not spelled correctly, and it must be exact to work. I did not tell you about environment variables. I told you about command line options, which you chose to ignore and try something else. Good luck

I have the same problem with shotcut and I’ve downloaded it from
The windows is too big to my screen and when I try to use full screen mode this appears in any place on it. I use Debian 9.

an image of problem:
thank you for any answer

You have the timeline open.
Click any of the x-boxes to close the windows if you don’t want them, you can always reopen them when you want to use them again.

Have you tried move these around? These will adjust the width of the windows.

Lastly, have you tried this?

Your screenshot does not clearly show a problem. If it is already “too big” why would you then try to use it full screen? And what is “this” in “this appears?”

You did not mention whether you tried the command line options I mentioned in my first reply above. I assume you did not. Why not try suggestions provided before posting for more help?

Try running shotcut with command line option --QT_SCALE_FACTOR=1

See related

Given the comment in that thread from pete about KDE, perhaps Qt5’s HiDPI behavior is not working well under GNOME.

This topic was automatically closed after 90 days. New replies are no longer allowed.