Use hardware decoder for preview (if possible)


#1

if there any way to make the preview in shotcut use hardware encoders instead of the cpu?


As you can see, the hardware decoder is not being used while it is playing.
(I am exporting a video as this screenshot was taken, hence high cpu usage and encoder usage)

I think this would make the preview a lot less choppy on pcs with more powerful graphics hards or hardware encoders. I dont know if this is even possible or if there is a setting for this, but it would be a cool improvement if it was fixable.

Thanks and sorry if this has a really simple answer that I didn’t know of.


#2

Go to Settings and pick “Display Method”. You probably have it on “Software”. Try “OpenGL” or “DirectX” and see how it works for you.


#3

Not at this time. Display Method is not anything about decoding; only display. It is not easy to integrate hardware-accelerated decoding, or it would be done already. This is already mentioned, a duplicate suggestion, and already on the road map even if not a published item.


#4

Oh ok. Shall I delete this post then?