Upload video on Youtube looks bad

There are a few postings on this topic, but I can’t find an answer.

My camera (Firefly 8SE) has recorded in 1080 at 60fps. The raw video plays back fine using vlc. If I encode the video using the Shotcut YouTube presets the Shotcut created video also plays perfectly with vlc, so Shotcut encoding is not degrading the video. When uploaded to YouTube, if displayed in full screen or cinema mode, with playback set to 1080p/60 the video is very pixellated - it is as though Youtube thinks the original video was a lower resolution than 1080 and it’s ‘upscaled’ it.

I’m sure it’s a setting somewhere, but for the life of me I don’t know !

Any help much appreciated.

In the Codec tap in the Export options, did you use “Quality Based VBR” for rate control? If you did was the quality at 60% (the default setting)? If it was try exporting it at a higher percentage like 70% or even a little more and see if it makes any difference.

Yes, using Quality Based VBR. This is a sample video:

Specs used are in the description for the video. The Shotcut exported video which was uploaded is perfect when viewed on my computer with vlc.

Immediately after you upload, YouTube does not have all resolutions and bitrates converted and ready. Usually, you first see low resolution. Wait a few hours, come back to the YouTube video, click the gear icon on its player, look at the choice of options, and ensure you are not watching a low res version.

1 Like

The video is on YouTube at 1080p60 quality.

If you view the video on YouTube in any of cinema, default or full screen mode, at the 6-17s mark clear pixelation on the lower half of the video is visible.

The file I uploaded as exported from Shotcut (and also the raw footage from the camera) displays perfectly with vlc with none of these artefacts, so I assume there is something YouTube doesn’t like. I can view plenty of other videos people upload without this problem.

Did you export using the “Youtube” preset? sometimes if you use other settings youtube will re-encode your video(even at the default resolution) and make quite a mess of things.

Yes. I’ve tried numerous permutations of the Youtube preset (interpolation, quality, GOP frames, bit rate) as well as various permutations of the settings suggested from this post on Reddit: https://www.reddit.com/r/shotcut/comments/4hxsi3/encoding_help/

Every option when uploaded to YouTube exhibits similar artifacts (some worse than others). As I’ve said, the encoded files exported from Shotcut play just fine with vlc, so it’s YouTube re-encoding and munging the video. Maybe there is some magic setting that “just works”.

My gripe is not with Shotcut - it is a fantastic program.

Did you resolve this problem? I now have the same issue with a 1080p30 ‘perfect’ sample being converted to pixellated mess with pulses every few seconds of a perfect frame.

1 Like

No. After trying a multitude of things, as well as encoding with Handbrake (again with a bunch of different settings), the same artifacts exist. I’m guessing the video changes too much in certain areas for the bit rate that YouTube uses to encode the video, hence the pixelation.


This topic was automatically closed after 90 days. New replies are no longer allowed.