Unexpected font issue

This is strange; I made a video three weeks ago and liked the font - there were no issues at all. So in my latest video I used the same font but although it looks right when its clip is selected, it looks bold when unselected; worse yet, it seems to be bold in the render.

So I opened my old project, copied some text with that font into the new project and it works fine. I do NOT have bold selected in the new project and I have examined the offending clips carefully, but I’m stumped! So for this time, I just edit the old wrking clip and replace the new ones with the edited old ones. But what in the world might be causing this?

I think I experienced this issue last week. I had a looong page of text with the font set to a low size. When the text filter was selected, the text looked normal. Unselect the filter and the text was displayed in bold. I don’t remember what font I used.
And now that I try to reproduce it everything is normal.

@Tyrannocaster you don’t mention it, but I guess you were using the Text: Rich filter?
Also, what font were you using?

Good to know that somebody else has experienced this! Yes, it’s Text: Rich, and the font in question is Monotype Corsiva, which is not a standard Windows font; I only added it a few weeks ago.

It looks like the Text: Rich filter applies a slight Bold to the text by default, even if the UI says that it is not enabled.
And it may depend on the Font used (I didn’t have time to make more tests)

Here’s what I did:

  • Track V1: White clip.
  • Track V2: Transparent clip.
  • Add Text: Rich filter to track V2
  • Write text, set font to Monotype Corsiva, color to black, size to 100
  • Add a Text: Simple to track V2 and use same text, same font, same color and size.

Here’s the result

Text: Rich on top, Text: simple on the bottom.
The Text: Rich text is obviously bolder then the Text: Simple text.

Then I selected the Text: Rich filter in the filters list, selected the text on the screen and pressed the B button twice:
rt5Xr5Qrh0

Here’s the result

They now both look the same.

So maybe you can try that workaround in your project @Tyrannocaster (select the text and press the B button twice) to see if it solves the issue.

1 Like

Fascinating! I would never have thought of that. I just finished the project, and I managed it by using a text clip from the old project which for some reason didn’t do this and replaced it with my new text. But why did it work okay the first time, I wonder; maybe I bolded it twice without realizing it? Luckily, there were not very many clips involved. But now I will have to go back into the project and try this out. Thank you so much!

Did you use the same version of Shotcut in your old project?
Maybe there a small bug with Text: Rich in the latest Shotcut version?
If I have time when I get back home from my appointment, I’ll try to check this out.
If not, then that will have to wait till I get back from my little vacations (fishing trip part 2)

Yes, same version; in fact, it’s the only version I can use on that computer, which runs Windows 7 so it can’t use the later versions, although I guess it could use older ones.

Your workaround sounds doable and I will try it when I"m not posting from my tablet like I am now.

The default document in Text: Rich does try to default to bold, but I see now that it is actually a demi-bold, and that does not turn on the Bold button. I think this is something that changed with the major Qt version upgrade a while back. I will change this for the next version to normal.