Unable to gpu encode nvenc with clips including MLT files

What is your operating system?
win11 amd3700 nvadia 3070ti

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

Shotcut versions 23 and 22 were picked up and tested in the portable version.
I get the same symptoms for both profiles 264/HEVC.

It seems to do GPU encoding when lining up raw mp4files etc on the timeline.
If I put MLT clips on it, it seems to stop with this error.

It doesn’t make sense, but if I check the preview quality adjustment checkbox, it seems to encode, but the resolution is preview quality.

I’m not sure if it’s a very minimal test file, but I’m pretty sure that just adding MLT from a timeline that can be gpu encoded in raw will cause an error, so I’m not sure if it’s just a test file.
I think the cause is a problem in loading MLT files, but has this been reported?

Is there a workaround for this problem?

The log says “interlaced encoding is not supported” because your project video mode has turned that on. You need to change it in Settings > Video Mode menu or Export > Video > Scan mode.

I think all interlaced parts should be progressive. The export and settings are HD 1080i 29.9fp in the profile.

The source on the timeline is also progressive.

First of all, as mentioned above, I have confirmed that I can gpu encode the raw mp4 progressive source in the HD1080i 29.9fp project.

If I put the mlt project in there as a clip, I get interlaced errors without fail.

  1. I have also confirmed that I can encode two HD1080i 29.9fp projects with gpu encoding, and if I use one of them as a clip to encode as in 1, I still get the interlacing support error. I can’t say for sure, but even if I change the type of video file I’m using, it always gives the same error, so I don’t think it has anything to do with interlacing as there seems to be no interlace setting.

Also, the default settings profile does not explicitly indicate whether it is progressive or interlaced, so I have also tried a custom profile with progressive settings.

I’ve also tried several auto profiles and 1080i at different fps, all the same.

I’ve also tried gpu driver ver’s that are the latest, slightly older, and slightly older as a result, but the type of error seems to be the same. The operating time of the pc does not seem to have anything to do with it either.

So it seems to be a hardware-specific problem or a problem when encoding MLT as a clip. I would like to know if this is a confirmed bug or if it is a problem that only occurs in my environment, because I can get the same error simply.

Again, this is your problem. Why is that so hard to understand? What is “profile” exactly (using the words in Shotcut’s English UI)?

That is impossible as noted in the Export log; it is a hard NVENC limitation. I think you are not paying close attention to your steps and the scan mode in the video mode and export. Why are you using a 1080i video mode when you want to encode with NVENC that does not support it? Especially when “the source on the timeline is also progressive.”

I have not been able to reproduce anything except when scan mode is interlace and try to export with NVENC, of course. If you continue to have a problem simply turn off the hardware encoder. It is not very important.

GPU encoding itself is done.

Saying that NVENC has 1080i for GPU encoding seems a little out of place in this conversation.

However, it is correct that 1080i is not supported as pointed out.
1080i single video file hevec/H246 profile
SETTING>MOVE MODE >CUSTUM 1920x1080 29.9FP Progressive can encode

If the file contains MLT
SETTING>MOVE MODE >CUSTUM 1920x1080 29.9FP Progressive gives interlace error.

Etc. If it is 30fp or more, no error will occur, so
SETTING>MOVE MODE >CUSTUM 1920x1080 29.9FP It is said that it is strange that it is progressive.

It’s a little hard to understand.
If it is 29.9fp, I feel that even if it is progressive, it is received as some kind of interlace if it is custom.

If you set the Scan mode in the export panel to progressive does the encode end succesfully?

Why do you want/use interlaced mode anyway? You don’t need to set video mode to interlaced even if your sources are interlaced video, deinterlacers are very good at converting these days and you’ll likely not even notice it.

This topic was automatically closed after 89 days. New replies are no longer allowed.