Unable to edit text

Basically, I can’t edit any text. Playing a clip with text on it when the specific clip is selected just results in some weird artifacts and the text basically disappearing.

This happens for both rich and simple text. Everything I typed is perfectly visible when exporting or when the current clip is unselected.

You can find a clip here: Imgur: The magic of the Internet

I’m currently on an up-to-date archlinux system, using Shotcut 22.12.21 (community repo). I have the exact same issue in an empty project.

It worked decently well a couple of weeks ago (still, with some weird behaivour, but decent). I have already tried cleaning ~/.local/share/Meltytech/Shotcut and ~/.config/Meltytech/Shotcut.conf, with no success.

Any kind of help would be massively appreciated :slight_smile:

As an experiment, would you be willing to download the official Shotcut portable build from the Shotcut website?

This would help us determine if your problem is coming from Shotcut, or the specific build you are using.

Thanks a lot for taking interest and answering this quickly. Using the build found inside of the tarball you linked does indeed seem to work. A possibility would be to just move the exacutable into /usr/bin, despite being a bit hacky it should work well enough (the only weird thing is that it almost looks sandboxed? https://i.imgur.com/RKHXpmB.png). Exactly the same happens with the AppImage, but I would have expected it there.

I was going to try using shotcut-git from the aur, but the compilation seems to fail (the package is also flagged out of date, I’m guessing because of a qmake syntax error).

One more issue I have (and have had some weeks ago too) is that editing text on a white background is decently annoying because of the typing indicator also being white; should I open a different issue for it?

Please ignore everything I said in the message above. I think I found out where the issue lies.

Running the executable found inside of the tarball directly results in the exact same issue. What seems to matter are the environnment variables specified in the launch script.

# Set up environment
# Run this instead of trying to run bin/shotcut. It runs shotcut with the correct environment.
CURRENT_DIR=$(readlink -f "$0")
export MLT_REPOSITORY="$INSTALL_DIR/lib/mlt-7"
export MLT_DATA="$INSTALL_DIR/share/mlt-7"
export MLT_PROFILES_PATH="$INSTALL_DIR/share/mlt-7/profiles"
export MLT_MOVIT_PATH="$INSTALL_DIR/share/movit"
export FREI0R_PATH="$INSTALL_DIR/lib/frei0r-1"
# Temporarily ignore user and default path because csladspa bug is crashing with
# LADSPA_PATH set, and Shotcut only needs the supplied SWH plugins.
# export LADSPA_PATH="$LADSPA_PATH:/usr/local/lib/ladspa:/usr/lib/ladspa:/usr/lib64/ladspa:$INSTALL_DIR/lib/ladspa"
export LADSPA_PATH="$INSTALL_DIR/lib/ladspa"
export QT_PLUGIN_PATH="lib/qt5"
export QML2_IMPORT_PATH="lib/qml"
bin/shotcut "$@"

So yea, the program is indeed mostly being sandboxed. Is there any way to change this without removing the working text editing?

Some noteworthy behaivours I have noticed (modifying only the mentioned variables, leaving the rest intact):

  • removing LD_LIBRARY_PATH makes the program use the correct theme but the timeline won’t render. It is not set on my system by default.
  • removing one or more of the MLT_* variables (except MLT_MOVIT_PATH) results in the program being unable to open any .mlt files
  • removing QT_PLUGIN_PATH or setting it to /lib/qt/plugins results in the program crashing (This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.)
  • removing QML2_IMPORT_PATH makes the program terminate with a segmentation fault.

Just in case it might matter, I have QT_QPA_PLATFORMTHEME set to qt5ct

I think this might be reproducable on any machine, but I have not tested it. Let me know immediatly if there’s anything else I should test :slight_smile:

I think you are trying to do something unsupported.

We can not support the Arch builds. You will need to talk to the Arch packagers if theirs does not work properly.

The .tar file from the Shotcut download page is intended to be used as a portable package. See the instructions on the website:

Linux portable tar users : No install required, simply extract the archive and run it. You can drag the Shotcut folder to copy and move it wherever you want. If double-clicking the icon in your file manager does not launch Shotcut, open Shotcut.app, and try double-clicking the shotcut shell script. Do not try to run bin/shotcut directly.

If the filter’s Background parameter is white or near white, yes that is possible, but the text editor UI does not know about the video colors. It would also be easy to add a thin black border to the cursor to deal with either.

That totally makes sense.

One thing: trying ti export using an hardware encoder (vaapi_h264) on the portable build seemed to end up failing the export almost immediatly. It worked fine when just using the cpu, though

This topic was automatically closed after 90 days. New replies are no longer allowed.