Unable to download


#1

Using 2 different computers; same result when trying to download 180102 win64 executable, or zip file from shotcut.org or shotcutapp. Get ‘can’t download’, ‘network error’, ‘forbidden’ messages using either Edge or Chrome. All other internet activity works fine. Any suggestions or issues with downloading atm? Tried older version of Shotcut with same result…
Thanks for your help. Looking forward to trying out this software :slight_smile:


#2

All links on the download page work fine here.
Sounds like you have a local problem.

https://productforums.google.com/forum/#!topic/chrome/7XBU6g6_Ktc


#3

I have the same problem downloading sometimes.
Try this site. It works pretty well.


#4

Thx, but same problem. Used Chrome browser, got to 23.5 MB of download, then stalled, then ‘Failed: network error’, tried to resume & immediately got ‘failed: forbidden’ message. If site owners say there’s nothing wrong with downloads guess I’ll look for a different program. Been attempting to d/l it for 2 days now…


#5

Did you visit the link I supplied regarding this??


#6

Hi Steve, Yes, did all the stuff Google/Chrome suggested (cleared history, cookies, changed destination folder, turned off firewall/anti-virus, made sure I have the latest version of Chrome, tried Edge, etc). This time I got to 29.9 MB before same error messages appear. Like I mentioned before, the same thing happens for me using a different laptop, and all other downloads/browsing/internet related activities work fine on both laptops, so it’s a mystery. Thanks anyway.


#7

You’re inferring there’s something with the shotcut downloads page and also the github page for older versions which is causing this problem for you.
Evidence is to the contrary as others are able to download from those servers without any issue.
So if both your laptops are functioning correctly, your AV isn’t blocking it, they are free of any malware and you aren’t using a VPN and/or a download manager the only differences seem to be your connection to the internet. This could be modem/router hardware or your service provider.
Too many variables for anyone here to hone in on the exact problem you’re having. But evidently the Shotcut or Github servers are not the reason.


#8

Well, I wasn’t ‘inferring’ anything; just letting you know what I’d done, and what was happening. I haven’t changed anything since the last failed attempt, but thought I’d try again before replying to your last message, and guess what; it downloaded completely with no errors :smiley:. Mystery solved (well not really, but I’m glad I can now install & try the program. Thanks for your time in looking into this; most appreciated.
Scott


#9

I tried to download a video for my youtube channel and then it came in a mlt format. So i tried using the export menu but i cant export my video as a mp4. please help.


#10

This off topic, please start a new topic/thread about your problem.


#11

An alternative, trustworthy, and supported download location is FossHub: https://www.fosshub.com/Shotcut.html

Shotcut’s download page uses GitHub and the project’s Releases page as linked to by @sauron above, and GitHub uses Amazon Web Services S3, both of which are about as reliable as it can get. However, even they suffer problems at times. I do not think FossHub uses the same infrastructure.


Downloads fail on Windows and Linux platforms
#12

@shotcut thank you for recommending us!

True, we do not use Amazon Web Services S3 for serving downloads. We used a separate CDN provider for the last four years. We had only two user incidents out of approximately 290.000.000 downloads, and those two issues were an ISP-POP related (something isolated). We would like to thank Shotcut team for keeping us in the loop and for their effort to update Shotcut each time.


#13

Your ‘DONATE’ link on the above fosshub linked page generates a 404.


#14

@Steve_Ledger thank you! Good catch!

I noticed there’s no donation option available for Shotcut, so I updated the link to point to this forum page:

Hope its ok, I’ve read all the comments pointing to an external page where users can buy shirts and other stuff to support Shotcut but just in case the link will change it will end up to a 404 page.

Please notify us if you would like this link to point somewhere else.

Thanks a lot!
FossHub