Un-used RAM as cause of slow preview?

Is it possible that very slow preview is caused by RAM not being used appropriately? I experience 100% CPU load, but 9,5 GB RAM is un-used; whereas 10.1 GB were un-used before starting Shotcut (of total 11,9 GB). That means that shotcut uses only 0.6 GB of RAM. Is this usual? (while previewing a 2.7 k video)? Or could this it be a hint to explain the slow preview?
I moved the topic from here: https://forum.shotcut.org/t/display-method/12705/6?u=steve2
I understand that preview is only partially supported by GPU, and I found a slight speeding up of estimated 25% when using Display-method “Automatic”, compared to “Software (Mesa)”.

Is the Video Mode fps the same as the 2.7k video?
Could you provide a screenshot of the properties window of the 2.7k video in Shotcut?

If CPU is at 100% it is very likely the bottleneck. RAM usage is complicated but don’t expect to use 3GB of ram if you play a 3GB file, you only need a very small amount of that file at a time and it would be very inefficient to load the entire file in memory.

You should probably avoid the display method Software (Mesa), as it will use more CPU power instead of relying on the more efficient/accelerated modes.

Are you using a laptop or a desktop? What CPU do you have? Higher resolutions video editing really demand very powerful desktops, my own laptop drops frames even on 1080p videos while the desktop with a Ryzen 7 2700x (16 cores) can playback decently 4k footage at roughly 10-20fps (of course if I apply filters all goes to hell).

I am curious if someone has the arm mac M1 cpu if it can playback smoothly any 4k video in Shotcut by default (as opposed to needing some special support to use the hardware acceleration in the chip).

Video mode matches the video (set to “automatic”).
Here screenshot of properties. grafik
Same tendency with any played video.
Using open GL or “automatic”, and preview scaling ‘360p’, preview happens in 1/3 of real speed. With no preview scaling it takes 6 seconds per frame and mostly skipping frames. (Proxy of course helps, is just a hindrance for smaller jobs). CPU is Intel i5-4200M 2,5 GHz.
Amazing is that VLC-player plays same video with 60 fps in full resolution or any other scaling. (With sharpening filter, still at 30fps; with rotation still at about 12 fps).

I made a video to your source specifications with Shotcut.
Exported video opened in Shotcut

Progressive - On
Realtime (frame dropping) - Off
With Display Method set to OpenGL, playing in Shotcut

VLC default settings

VLC’s report of the source file

Exported file specifications using MediaInfo.

All screenshots are taken after a reboot of the computer with nothing else running.

Preview Scaling at 360, using Hardware Encoder

Shotcut 22.04.25

My computer:
Windows 10 Home
i7-7700k (4.3GHz), 32 GB Ram, GTX 1070 (8GB), SSD drives, CPU water-cooled, 6 case fans.

I have been able to play 4K60 without dropping frames in Shotcut’s Source player for a few years now on my multi-core desktop systems as long as the Video Mode matches (use Automatic). This claim is based on not seeing continual “dropped video frame” messages in View > Application Log periodically while playing. (This log dialog does not update itself.)

I think this is where your problem lies, you are using a rather old laptop CPU (released in 2013/14), these are very limited due to power and cooling constraints of the small laptop space so not ideal for so high definition video editing. Proxy might be your only choice for smooth editing.
What camera are you using for the 2.7k clips? Many action cams create proxies themselves and can be very useful for editing (gopro and dji I think do this automatically).

Hmm, you are right for the source player with no project open, I just gave it a bunch of 4k 30/60/30vfr clips and they do play smoothly with almost no dropped frames in the source player (CPU constant at 50-60%).

Weirdly, if I have a poject open (with stuff in timeline) and try to play a separate 4k clip in the source player (the one that didn’t have frame drops before) I get around +100 dropped frames every 3-4s:

[Debug ] [consumer sdl2_audio] dropped video frame 1644
[Debug ] [consumer sdl2_audio] dropped video frame 1645
[Debug ] [consumer sdl2_audio] dropped video frame 1646
[Debug ] [consumer sdl2_audio] dropped video frame 1647
[Debug ] [consumer sdl2_audio] dropped video frame 1648
[Debug ] [consumer sdl2_audio] dropped video frame 1649
[Debug ] [consumer sdl2_audio] dropped video frame 1650

With a project open, a video mode is established that Source player now also follows (so you can see how a media will appear when it is added to the project including possibly filters). Now the video mode does not match the video you loaded in Source, and it is scaling in software. (There is separate hardware scaler that adapts the in-memory video to the UI window.)

Ok, that makes sense, the project is a different resolution and fps so extra processing needs to be done.

This topic was automatically closed after 90 days. New replies are no longer allowed.