UI is suddenly zoomed in, making Shotcut impossible to use. Please help me fix this

Hi there.
I’ve been using Shotcut for years now, and I recently updated it to it’s most recent version, and suddenly it’s so clunky and zoomed in, in awful places and I can’t fix it. I’ve tried uninstalling and reinstalling the program, as well as reverting back to older versions but it doesn’t fix it.
Attached you will see an image of what I mean. The Filters tab is so zoomed in I have to scroll a tonne up and down just to change the zoom on my video.
I’ve been using Shotcut for so long, and this has made it so hard to use and so un-enjoyable as a software. I really don’t want to have to find an alternative software but I can’t edit videos like this.
Can someone help me with this? I’m sure there’s a simple CRTL command that I’m missing.

Left-click and resize the windows like this:

Hi there! Thanks for your help, but after using the product for 2+ years I know how to resize windows. My issue is the verticality. As you can see, in order just to adjust the zoom size, I have to scroll down a tonne, whereas before it all fit in perfectly.

Hi @TETR15

What are the Scale and Layout settings on your computer?

Here’s what my Shotcut window looks like on Windows 10 at 1920 x 1080

Not sure if your monitor is high DPI.
If so, have you tried this?

Source: Shotcut - Frequently Asked Questions

I suspect Windows system display scaling is set to 150% or 200% and then you want want to use --QT_SCALE_FACTOR 1 to reduce Shotcut’s size. Except it does not always work for whatever reason (in the Qt programming library we use). There is another way to keep Windows Settings as-is but change Shotcut:

  • right-click the app icon
  • choose Properties
  • click the Compatibility tab
  • click Change high DPI settings near the botttom
  • check the box near the bottom Override high DPI scaling behavior
  • in the drop-down directly below this checkbox choose System
  • click OK
  • start or restart Shotcut

In Shotcut’s View menu, you can also turn off text below the icons and choose to use small icons to give yourself more space in the UI.

1 Like

Thank you so much. It turns out yes, the High DPI was the issue. It’s all better now. Again, thanks so much.


This topic was automatically closed after 90 days. New replies are no longer allowed.