UI Font size - Windows 10

I have struggled with the UI font size on Windows 10 intermittently.

Following on from this post: https://forum.shotcut.org/t/gui-font-size-screwed-up-after-update/19494/4 I’m please to say that I have worked out a solution for me at least.

To note:

  1. QT_SCALE_FACTOR did not work for me (it functions, but only makes the problem worse. If I set it to <1 then nothing is visible).
  2. Changing the compatibility High DPI does not work for me (no effect at all).

I have a 1280x1024 screen with the system font size set to 100%.

  1. You can see the default view below on the left. The font size is correct on the “windows” menus (File / Edit / View etc), but not on the rest of the app.
  2. If you change the shortcut settings to compatibility mode: as per the middle of the screenshot then
  3. the view is (much better!) as per the right.

Hope this helps someone. It would also be great if the QT library was updated to support Windows 10 properly, but I’m happy enough with this workaround for now.

1 Like

Many thanks for this tip! On my previous PC, I had Shotcut installed on Windows 10 and the font size was consistent with the rest of the menus. I upgraded to Windows 11 with no impact on the font size.
When I installed Shotcut on a new Windows 11 machine, I had exactly the problem you describe: the font size inside the frame was way too big.
I didn’t have the reflex to test the Windows 8 compatibility mode but you had the right intuition.
PS: As for you, using QT_SCALE_FACTOR increases the font size even more.

@Dan Dennedy: 1- Many thanks for this great tool 2- The above problem seems completely reproducible; maybe you can take a look?

This topic was automatically closed after 90 days. New replies are no longer allowed.