UI crashing on Linux system with nvidia

does shotcut have an issue with nvidia graphics? i’m consistently getting crashes when i try to undock the timeliine. shotcut closes faster than if i hit ctl-q. just blinks off the screen. all other ui elements seem to undock just fine. tried the current version as both snap and portable, both 64bit. same behavior in each. system is kubuntu64 v18.04 lts with nvidia gtx760 and proprietary driver 390.116.

thanks,
babag

I used nvidia exclusively for years on Linux until about 1.25 years ago, and I never experienced this problem. In the meantime, I upgraded Qt in our builds to v5.9. The timeline uses Qt Quick QML, which is a very high level API that uses OpenGL for rendering. I do not have NVIDIA hardware at the moment on a Linux box. You can try the flatpak version, which uses Qt 5.12 to see if it makes a difference. Otherwise, you can just continue to use Shotcut with the timeline docked or try to debug this yourself.

thanks. i’ll give the flatpak a go first.

exactly same behavior using flatpak install. too bad. bummer.

thanks,
babag

You might need to uninstall all those shotcut apps you installed. Then try installing AppImage

https://shotcut.org/download/

Also probably worth reporting your issues to the Kubuntu devs, hopefully they can fix that bug in their shotcut port.

He already tried the portable and snap, which are the exact same builds as the AppImage and similar benefits (dependencies bundled).