Two bugs about Filter > Text

First:
The font choose window is too big to operate. I can not setup the font size.
Add filter > text simple , check the “Use font size” box, then click the button on the left side of the checkbox, the bug appeared.
Below is the screencapture.

This problem only appears in flatpak version. Appimage version is OK.
OS: Debian Stretch 9.11/ Gnome/shotcut 19.10.20 ( flatpak )


Second:
In the text edit area, I can not input Chinese(zh-cn), so, I input the text in gedit file and then copy it to clipboard, then trun back to shotcut and paste text from clipboard into the text area.

When pressed Ctrl+Space, there is no change in the input method, it can’t be displayed like libreoffice, only English can be entered.
In the libreoffice software, the Chinese input method can input Chinese normally.

This problem appears in the three filters of Text > Simple & Text > HTML & Text > 3D .
This problem appears in both flatpak version and appimage version of shotcut.
In the filter Text > HTML > Blank HTML, I checked the View Source Tab and the source code include meta charset="UTF-8"

OS: Debian Stretch 9.11/ Gnome/shotcut 19.10.20 ( flatpak & appimage)


Submit your own fixes for these as I have no intention to work on them. The first bug is probably in Qt; we just make a call to open a font dialog. Qt and the OS toolkit take care of the rest. Surely, one of the billion people in China can figure out how to fix the text input for their language.

Excuse me, do you mean that the problem of Chinese input is because of the the package of the shotcut dependency or related system settings? It has nothing to do with shotcut software, even the appimage version of shotcut, right ?

ps:
I can input Chinese in libreoffice. The Chinese input method(fcitx) works fine.

ps:
I had modify the bug descriptions with bold text.

Thank you.