Trying to run program from "shotcut" shell script gives syntax error

I have read the directions on getting shotcut to run in GNU/Linux, as follows:

If double-clicking the icon in your file manager does not launch Shotcut, open, and try double-clicking the shotcut shell script.

I’m my distro’s file manager (Dolphin) and displaying the shotcut directory, located as in System Info (below). Does ‘the icon’ (term used in directions) refer to a file named Shotcut.desktop? Should ‘the icon’ be a distinctive ‘shotcut icon’? I don’t have that. The file is displaying a default icon that looks like a page with simulated lines of text.

Clicking (or, double-clicking) on this does not open launch Shotcut. It creates an black entry in the TaskBar (bottom of screen) with the title Shotcut and a spinning progress indicator. There is no ‘Shotcut window’ appearing on the screen. The spinning indicator spins for perhaps 30 seconds, and finishes when the taskbar entry and the word Shotcut both disappear.

:question: This is completely different from what is expected, after reading the directions. Can someone tell me what is happening?

The second suggestion – if the first doesn’t work – is to double-click the shotcut shell script, located in the directory. This file has a default icon that looks like a page with simulated text lines, and a black terminal screen in the lower-right. Double-clicking this does absolutely nothing, on my system.

As an attempt to trouble-shoot why the double-click appears to do nothing, I right-clicked the same file and selected Actions -> Run in Konsole (KDE’s name for terminal). The terminal window opens, showing the following:
bin/shotcut: 1: bin/shotcut: Syntax error: "(" unexpected
It seems the shell script has crashed with an Syntax error, so obviously there will be no progress toward running the program.

:question: Why does following the direction to ‘double-click the shell script’ not launch the program and what should I do now?

System Info:
Linux Mint 17.3 KDE, 32-bit
location of directory:

P.S.: Just noticed something – while the download is not labeled as to whether it’s a 32- or 64-bit version, the filename does contain the sequence ‘64’. If this means what I think it does, and this is the reason for my problem, then please advise, where’s a download link/PPA for an (up-to-date!) 32-bit GNU/Linux version?

I think linux version are 64bits only…

This is the last one I think

Old versions here :

Thanks! I suppose that would be the file shotcut-debian7-x86-150506.tar.bz2.

I’ll give it a try and see how it compares with my other 32-bit choices – bearing in mind that some of the others have been more-recently updated. If it shows enough promise that I want to run the latest version, I’ll either have to boot into Windows for video editing – or wait until my current hardware is replaced with 64-bit.

If I’m connect, Windows users have the option of running the latest Shotcut version on 32-bit hardware.

A few weeks ago, it was told that it could be done… For some releases, not all of them.
We will see

:confused: Sorry, I don’t understand. You were told (by the Shotcut developer/s?) that something new was in the offing for users with 32-bit hardware?

The ‘it’ in your reply – refers to the developer compiling the source into a GNU/Linux version (for a recent release) that will run under 32-bit hardware? Or, you were saying that users would have to run an old 32-bit version if they only have 32-bit hardware?

I’m just wondering if I should continue returning to the Shotcut site, waiting for a (current and recent) 32-bit GNU/Linux version? Until seeing your reply, I had resigned myself to this not being possible.

Sorry I didn’t want to mislead you.
It was advised to try to compile it & to share it if ok.
But no answer after that.
Maybe you can try by yourself.