Transitions turning red with GPU effects


#1

Hello,

I have a strange bug on my computer, I suspect driver issues but I am not sure. When I export a video with a transition, and if there is at least one GPU effect (for example, Contrast), then the transition is completely buggy and colored with red.

This does not affect playing inside Shotcut, only after export.

Any thoughts about this issue ?

Here is a link towards a simple export video:

I am using latest Shotcut version 18.1.

Thanks a lot and best regards,
Stephane


Problem with redness
#2

Not sure what you mean by ‘GPU effect’. I you have GPU processing enabled, disable it. It’s experimental and known to cause oddities.


#3

Oh, thanks a lot for this ultra fast response.

I mean, any filter which can be applied on a video, which is categorized as “GPU” effect. For example, change of contrast, saturation, or sharpness.

Is it possible to use these filters as well as transitions without GPU processing enabled ? If I try to uncheck it, then I cannot open my project anymore and I should edit the mlt file to remove the movit functions, which ends up removing transitions and video filters…


#4

I don’t see any such category as GPU Effect, maybe because I never enable GPU processing. All filters and transitions are available without GPU Processing enabled.


#5

I see, If I start new project and remove GPU processing, I can use these effects as well without hardware acceleration. And this time, the export is fine.

Is there any trick to change in the mlt file so that I can convert all my GPU processing filters into CPU ones instead of removing them and recreating them by hand ?

Thanks a lot for your help!


#6

I have no idea, sorry. I have always taken ‘GPU Processing (experimental)’ to mean ‘Warning - use at own risk’ , so I never used it when there was an important edit involved.


#7

There is no clean way to convert a GPU filter into the corresponding non-GPU filter in an existing MLT file. Some of them have similar parameters, but some of them do not match up at all.


#8

OK, I will remove all the movit effects and remake them by hand without GPU processing, I do not have too much of them.

Thanks for the support


#9

WORKAROUND:
For the entire track, add the “Rotate and Scale” filter. (Leave it at the default 0.0,100%,0,0 - thus making no change to your video.)
The “Red” transitions appear properly.

The magic of how this works is found in another thread, Adding Fade in and fade out filters.


#10

This is no workaround. GPU Effects were/are experimental, and work differently from one computer to the next, meaning either you had excellent results, to having Shotcut crash every time the project was opened. GPU Effects are now disabled/hidden with 18.11.18, and are not supported.

As @brian pointed out, three posts up, there no clean way to fix the project.

Best practice: Use the newest version by >> downloading here <<, and to start a new project instead. Or if you choose to use an older version, leave GPU effects off. And if you want to experiment with GPU effects. Have a master copy of your project, duplicate/copy that to projectGPU.mlt then with a copy of the mlt, experiment with GPU effect.

Having backup copies of your projects files, as you work, is just good practice. If you work on a project daily, then every day would be a new version save. The mlt projects save files take such little room, as they are not video file, but lines of XML code.


#11

Totally NOT a Best Practice. 18.12.23 (which automatically installed itself today) is unstable even with GPU disabled, and it totally disables the use of Screen 0 as an External Monitor, which was working perfectly before and had and has become essential for my editing work.


#12

Shotcut is active in Screen 0 (Windows Display #1)
2018-12-24_01-30-22

Shotcut is active in Screen 1 (Windows Display #2)
2018-12-24_01-30-07

Then move Shotcut to Screen 1. Now you’ll have the option to open Screen 0.


#13

That is exactly what I attempted. Screen 0 will not highlight, therefore will not select.


#14

I use Windows 10 Home 1809, and these are the settings I have for my two monitors, and it works fine for me. All versions of Shotcut.
ApplicationFrameHost_2018-12-24_01-38-50

ApplicationFrameHost_2018-12-24_01-39-32


#15

multiple clicking back and forth between the three available choices, now it finally has resumed working as before.

This after many crashes, some of them bringing down the operating system with it.

It would seem that the “fix” was that when I re-installed Davinci, that install corrected whatever Linux or video driver parameters etc. that the upgrade to 18.12.23 had broken.

I have no doubt that 18.12.23 is stable on Windows 10 (I wish Windows 10 was working on my computer, but that’s another story) However, Shotcut 18.12.23 is highly unstable when running under Ubuntu Linux.


#16

Re: " leave GPU effects off. And if … experiment with GPU effects."

The ONLY reason I switched to Shotcut from a competitor, originally, was that Shotcut supports the GPU. Without using the GPU, Export uses all of the CPU power for unacceptable long periods (385% of a possible 400% on an AMD-64 with 4 cores, for upwards of an hour). By enabling GPU effects, CPU consumption is reduced to 230% out of 400%, allowing for other productive work during exports, and the total export time is reduced by 20% to 50%, thus increasing productivity by reducing turnaround.

The minor instabilities of Shotcut GPU are a small price to pay for such a performance increase.

The instabilities of 18.12.23 under Linux appear to be, if anything, worse when the GPU is disabled.


#17

Starting with Shotcut 18.11.13
https://shotcut.org/blog/new-release-181113/ New Version 18.11: And Hardware Encoding For All

Listed in the Downloads page:
2018-12-24_03-40-50


#18

18.11.13 is great. Reversion to that version, and redefining 18.12.23 as “beta”, would be a good idea.

The performance improvements of 18.11.13 arr marvelous. Nevertheless, if filters are used, the performance of 18.11.13 suffers. Enabling GPU on 18.11.13 drops the CPU usage to acceptable levels while cutting about 20% from the processing time for Export.


#19

As a software (and microcomputer hardware) engineer with more than five decades of experience, I would speculate that the focus on fixing performance and bug issues in Windows 10 (which is, granted, by far the largest market) caused a tunnel-vision that overlooked the effect that those “fixes” would have on other OS’s that Shotcut also supports, such as Linux.


#21

If only I was able to run Windows 10 on my current hardware…