Total computer freeze every time Shotcut is used

Hello everyone! I recently discovered this program and it would be for me, if it weren’t for the fact that it is improbable to use it because on 10 minutes of use, just to give an example, my computer freezes at least 4 times and I have to switch it off and on again.
It ONLY happens with Shotcut, it is not a problem that occurs with other programs and uses. I also tried to use the portable version but nothing, the computer always freezes the same way.
It is not a problem of a single project, I have tried dozens of videos, of any weight, format and duration, the computer crashes constantly, to the point that I cannot use the software. Is it an incompatibility problem with my hardware or version of Windows?
Is there anything I can do?

My specs
i7 9700k
RTX 2080
16 Gb of RAM 4000 Mhz
Windows 10 updated to the latest version

You did not provide a Shotcut version not that it really matters in this case. This is not a bug and never happens to me. An application bug should never be able to make your computer or operating system freeze up. If it does, then it is a bug in the operating system kernel or more likely a driver. Usually when this happens, it is because the computer has overheated in which case the operating system and drivers cannot do much. This happens in Shotcut because it uses the CPU more heavily than probably any other application you use, and that is not a bug either. Video processing is naturally heavy, and Shotcut uses the CPU more than the GPU.

Right now I’m using the portable version 21.01. 29. On the subject of cpu heating it is strange, I have a liquid cooling and I do heavy rendering of 3D graphics that stress the cpu a lot and this does not happen. If I had cpu stress problems I would have largely noticed it since I use software that stresses a lot.
Is there any information on drivers that could cause such problems with Shotcut that you know of?

Did you disable GSYNC in nvidia control panel for windowed mode?

Seen that suggestion somewhere else and it works for me